aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde-turba
diff options
context:
space:
mode:
Diffstat (limited to 'mail/horde-turba')
-rw-r--r--mail/horde-turba/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index de7e2932ba40..850e007e9ae5 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -39,6 +39,9 @@ LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2 \
RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeTurba
DOCS= COPYING README docs/CHANGES docs/CREDITS \
docs/INSTALL docs/turba.dia docs/turba.pdf
CONFFILE= attributes.php conf.php html.php menu.php \
@@ -109,11 +112,10 @@ do-install:
@${CHOWN} -R www:www ${TURBADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.turba ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${HORDE_INC}/httpd.conf.turba
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeTurba
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTTURBA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.turba.beforeTurba
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTTURBA::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterTurba