aboutsummaryrefslogtreecommitdiffstats
path: root/mail/imapsync/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/imapsync/Makefile')
-rw-r--r--mail/imapsync/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/mail/imapsync/Makefile b/mail/imapsync/Makefile
index 8ff13af06d71..ac386d7efa0d 100644
--- a/mail/imapsync/Makefile
+++ b/mail/imapsync/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= imapsync
-PORTVERSION= 1.178
+PORTVERSION= 1.179
CATEGORIES= mail perl5
MASTER_SITES= http://www.linux-france.org/prj/imapsync/dist/
EXTRACT_SUFX= .tgz
@@ -16,13 +16,16 @@ COMMENT= IMAP synchronization copy or migration tool
BUILD_DEPENDS= ${SITE_PERL}/Mail/IMAPClient.pm:${PORTSDIR}/mail/p5-Mail-IMAPClient \
${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC
+ ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PERL5= yes
NO_BUILD= yes
+POD2MAN?= pod2man
-PLIST_FILES= bin/imapsync
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
.include <bsd.port.pre.mk>
@@ -31,6 +34,8 @@ IGNORE= requires Perl 5.6 or newer. Install lang/perl5.8 and try again
.endif
do-install:
+ ${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1
.include <bsd.port.post.mk>