aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libesmtp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/libesmtp/Makefile')
-rw-r--r--mail/libesmtp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index b3cfaf262e2a..4bbf2ec23936 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -20,6 +20,7 @@ USE_GMAKE= yes
USE_OPENSSL= yes
USE_LIBTOOL= yes
USE_PERL5_BUILD=yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -33,6 +34,9 @@ CONFIGURE_ARGS= --enable-all --disable-isoc
DOCS= AUTHORS ChangeLog NEWS Notes README TODO
EXAMPLES= examples/*
+post-patch:
+ @${REINPLACE_CMD} 's,memrchr,memchr,' ${WRKSRC}/smtp-tls.c
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}