aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libpst/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/libpst/Makefile')
-rw-r--r--mail/libpst/Makefile31
1 files changed, 18 insertions, 13 deletions
diff --git a/mail/libpst/Makefile b/mail/libpst/Makefile
index 4490c5b9b602..1d2064231837 100644
--- a/mail/libpst/Makefile
+++ b/mail/libpst/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libpst
-PORTVERSION= 0.6.37
+PORTVERSION= 0.6.45
CATEGORIES= mail converters
MASTER_SITES= http://www.five-ten-sg.com/libpst/packages/
@@ -19,29 +19,34 @@ USE_ICONV= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --disable-python
-.if exists(${LOCALBASE}/bin/convert) || defined(WITH_PST2DII)
+OPTIONS= PST2DII "allow Summation Document Image Information output" off
+
+MAN1= lspst.1 pst2dii.1 pst2ldif.1 readpst.1
+MAN5= outlook.pst.5
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PST2DII)
+CONFIGURE_ARGS+= --enable-dii=yes
BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
PLIST_SUB+= PST2DII=""
.else
+CONFIGURE_ARGS+= --enable-dii=no
PLIST_SUB+= PST2DII="@comment "
.endif
-MAN1= lspst.1 pst2dii.1 pst2ldif.1 readpst.1 readpstlog.1
-MAN5= outlook.pst.5
-
post-patch:
- ${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -i "" -e 's/malloc.h/stdlib.h/g'
- ${REINPLACE_CMD} -e 's;doc\/@PACKAGE@-@VERSION@;doc\/@PACKAGE@;g' ${WRKSRC}/Makefile.in \
- ${WRKSRC}/html/Makefile.in
-
+ ${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -i "" \
+ -e 's/malloc.h/stdlib.h/g'
+ ${REINPLACE_CMD} -e 's;doc\/@PACKAGE@-@VERSION@;doc\/@PACKAGE@;g' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/html/Makefile.in
.ifdef(NOPORTDOCS)
-INSTALL_TARGET= install-exec
-
-post-install:
- @(cd ${WRKSRC}/man && ${GMAKE} ${MAKE_ARGS} install)
+ ${REINPLACE_CMD} -e '/SUBDIRS =/s/=.*/= src man/' -e '/html_DATA =/d' \
+ ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>