aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libspf2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/libspf2/Makefile')
-rw-r--r--mail/libspf2/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/mail/libspf2/Makefile b/mail/libspf2/Makefile
index 62cc6cc93211..821fbcd1ba4f 100644
--- a/mail/libspf2/Makefile
+++ b/mail/libspf2/Makefile
@@ -5,21 +5,26 @@
# $FreeBSD$
#
-PORTNAME= libspf2
-PORTVERSION= 1.2.5
-CATEGORIES= mail
-MASTER_SITES= http://www.libspf2.org/%SUBDIR%/
+PORTNAME= libspf2
+PORTVERSION= 1.2.5
+CATEGORIES= mail
+MASTER_SITES= http://www.libspf2.org/%SUBDIR%/
MASTER_SITE_SUBDIR= spf
-MAINTAINER= mnag@FreeBSD.org
-COMMENT= Sender Rewriting Scheme 2 C Implementation
+MAINTAINER= mnag@FreeBSD.org
+COMMENT= Sender Rewriting Scheme 2 C Implementation
-CONFLICTS= ${PORTNAME}-1.0.*
+CONFLICTS= ${PORTNAME}-1.0.*
-INSTALLS_SHLIB= yes
-HAS_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+post-patch:
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>