aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailscanner
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mailscanner')
-rw-r--r--mail/mailscanner/Makefile1
-rw-r--r--mail/mailscanner/files/patch-bin:update_virus_scanners12
-rw-r--r--mail/mailscanner/files/patch-lib:MailScanner:MessageBatch.pm14
3 files changed, 27 insertions, 0 deletions
diff --git a/mail/mailscanner/Makefile b/mail/mailscanner/Makefile
index 8cdd5cb18bc6..00cf386781c8 100644
--- a/mail/mailscanner/Makefile
+++ b/mail/mailscanner/Makefile
@@ -7,6 +7,7 @@
PORTNAME= MailScanner
PORTVERSION= 4.29.7
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.sng.ecs.soton.ac.uk/mailscanner/files/4/tar/
DISTNAME= ${PORTNAME}-${PORTVERSION}-${PATCHLEVEL}
diff --git a/mail/mailscanner/files/patch-bin:update_virus_scanners b/mail/mailscanner/files/patch-bin:update_virus_scanners
new file mode 100644
index 000000000000..a160c97304cc
--- /dev/null
+++ b/mail/mailscanner/files/patch-bin:update_virus_scanners
@@ -0,0 +1,12 @@
+--- ../MailScanner-4.29.7.orig/bin/update_virus_scanners Wed Apr 28 13:38:29 2004
++++ bin/update_virus_scanners Wed Apr 28 13:39:10 2004
+@@ -8,7 +8,8 @@
+ # the lockfile is not meant to be perfect, it's just in case the
+ # two cron scripts get run close to each other to keep them from
+ # stepping on each other's toes.
+-[ -f $LOCKFILE ] && exit 0
++
++[ -f $LOCKFILE ] && [ "`find $LOCKFILE -type f -mmin +60 -print`" = "" ] && exit 0
+ trap "rm -f $LOCKFILE" EXIT
+ touch $LOCKFILE
+
diff --git a/mail/mailscanner/files/patch-lib:MailScanner:MessageBatch.pm b/mail/mailscanner/files/patch-lib:MailScanner:MessageBatch.pm
new file mode 100644
index 000000000000..c9b898bbeb35
--- /dev/null
+++ b/mail/mailscanner/files/patch-lib:MailScanner:MessageBatch.pm
@@ -0,0 +1,14 @@
+--- ../MailScanner-4.29.7.orig/lib/MailScanner/MessageBatch.pm Wed Apr 28 13:38:25 2004
++++ lib/MailScanner/MessageBatch.pm Wed Apr 28 13:39:29 2004
+@@ -472,6 +472,11 @@
+ MailScanner::Config::LanguageValue($message, 'cantanalyze') . "\n";
+ $message->{othertypes}{""} .= 'e';
+ }
++ if ($message->{toomanyattach}) {
++ $message->{otherreports}{""} .=
++ MailScanner::Config::LanguageValue($message, 'toomanyattachments') . "\n";
++ $message->{othertypes}{""} .= 'e';
++ }
+ if ($message->{badtnef}) {
+ $message->{entityreports}{$this->{tnefentity}} .=
+ MailScanner::Config::LanguageValue($message, 'badtnef') . "\n";