aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mairix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mairix/Makefile')
-rw-r--r--mail/mairix/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/mail/mairix/Makefile b/mail/mairix/Makefile
new file mode 100644
index 000000000000..469bb2eb657c
--- /dev/null
+++ b/mail/mairix/Makefile
@@ -0,0 +1,28 @@
+# ports collection Makefile for: mairix
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+# Date created: 2003-03-27
+#
+# $FreeBSD$
+#
+
+PORTNAME= mairix
+PORTVERSION= 0.10
+CATEGORIES= mail
+MASTER_SITES= http://www.rrbcurnow.freeuk.com/mairix/
+
+MAINTAINER= obraun@FreeBSD.org
+COMMENT= Indexing and searching in Maildir or MH folders
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC/d ; /^CFLAGS/d' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mairix ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/mairix.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>