aboutsummaryrefslogtreecommitdiffstats
path: root/mail/milter-callback
diff options
context:
space:
mode:
Diffstat (limited to 'mail/milter-callback')
-rw-r--r--mail/milter-callback/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/mail/milter-callback/Makefile b/mail/milter-callback/Makefile
index 892067426363..0df7fafcc473 100644
--- a/mail/milter-callback/Makefile
+++ b/mail/milter-callback/Makefile
@@ -24,6 +24,15 @@ MAN8= milter-callback.8
EXTRACT_AFTER_ARGS= | (${MKDIR} ${WRKSRC}; ${TAR} -xf - --no-same-owner \
--no-same-permissions -C ${WRKSRC})
+OPTIONS= SPF "build with SPF support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SPF)
+MAKE_ENV+= WITH_SPF=yes
+LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|" \
${WRKSRC}/${PORTNAME}.c
@@ -43,4 +52,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>