aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mutt-devel/Makefile')
-rw-r--r--mail/mutt-devel/Makefile31
1 files changed, 28 insertions, 3 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 8ed6236a46c9..1b55873c310d 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -49,10 +49,13 @@
#
# If you want to enable the pgp_outlook_compat function for use with pgp define:
# WITH_MUTT_PGP_OUTLOOK_PATCH
+#
+# If you want to enable some functions whoch improve maildir handling define:
+# WITH_MUTT_MAILDIR_PATCH
PORTNAME= mutt-devel
PORTVERSION= 1.3.99
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES+= mail
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
@@ -98,6 +101,18 @@ pre-build:
s/^(AUTOMAKE = ).+/\1${AUTOMAKE}/; s/^(AUTOHEADER = ).+/\1${AUTOHEADER}/" \
${BUILD_WRKSRC}/Makefile
+.if defined(WITH_MUTT_MAILDIR_PATCH)
+.for file in Makefile.am globals.h init.h mh.c mutt.h
+EXTRA_PATCHES+= ${WRKSRC}/patch-${file}
+pre-patch::
+ ${CP} ${PATCHDIR}/extra-maildir-patch-${file} ${WRKSRC}/patch-${file}
+.endfor
+.for file in maildir_clean_dir.h maildir_clean_dir.c
+pre-patch::
+ ${CP} ${PATCHDIR}/${file} ${WRKSRC}/${file}
+.endfor
+.endif
+
.if !defined(PATCH_VERSION)
PATCH_VERSION= ${PORTVERSION}
.endif
@@ -294,7 +309,7 @@ PLIST_SUB+= SUB_ADD_D="@comment "
PLIST_SUB+= SUB_ADD_E="@comment "
PLIST_SUB+= SUB_ADD_F="@comment "
PLIST_SUB+= SUB_ADD_G="@comment "
-PLIST_SUB+= SUB_PGP_A="@comment "
+PLIST_SUB+= SUB_PGP_A=""
.else # patches
PLIST_SUB+= SUB_ADD_A="@comment "
PLIST_SUB+= SUB_ADD_B="@comment "
@@ -330,11 +345,21 @@ PLIST_SUB+= SUB_PGP_A="@comment "
post-patch::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
.endif
-.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH)
+.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH) && !defined(WITH_MUTT_MAILDIR_PATCH)
PLIST_SUB+= SUB_PGP=""
.else
PLIST_SUB+= SUB_PGP="@comment "
.endif
+.if defined(WITH_MUTT_MAILDIR_PATCH) && !defined(WITH_MUTT_PGP_OUTLOOK_PATCH)
+PLIST_SUB+= SUB_MAILDIR=""
+.else
+PLIST_SUB+= SUB_MAILDIR="@comment "
+.endif
+.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH) && defined(WITH_MUTT_MAILDIR_PATCH)
+PLIST_SUB+= SUB_MAILDIRPGP=""
+.else
+PLIST_SUB+= SUB_MAILDIRPGP="@comment "
+.endif
.if ${SGML_USED} == yes
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
post-patch::