aboutsummaryrefslogtreecommitdiffstats
path: root/mail/opendkim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/opendkim/Makefile')
-rw-r--r--mail/opendkim/Makefile82
1 files changed, 52 insertions, 30 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index ed607b5af877..69b7412e98a4 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -1,34 +1,42 @@
# New ports collection makefile for: opendkim
-# Date created: 2009-08-26
-# Whom: Hirohisa Yamaguchi <umq@ueo.co.jp>
+# Date created: 2009-08-26
+# Whom: Hirohisa Yamaguchi <umq@ueo.co.jp>
#
# $FreeBSD$
#
PORTNAME= opendkim
-PORTVERSION= 1.1.2
-PORTREVISION= 1
+PORTVERSION= 2.1.3
CATEGORIES= mail security
MASTER_SITES= SF/opendkim
MAINTAINER= umq@ueo.co.jp
-COMMENT= DKIM milter implimentation
+COMMENT= DKIM library and milter implimentation
GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_RC_SUBR= milter-opendkim
USE_LDCONFIG= yes
-MAN_COMPRESSED= no
-MAN3= ar.3
MAN5= opendkim.conf.5
-MAN8= opendkim-genkey.8 opendkim-testadsp.8 \
- opendkim-testkey.8 opendkim.8
-PORTDOCS0= FEATURES INSTALL KNOWNBUGS LICENSE LICENSE.Sendmail \
- README RELEASE_NOTES RELEASE_NOTES.Sendmail
-PORTDOCS= docs/*
+MAN8= opendkim-genkey.8 opendkim-genzone.8 \
+ opendkim-testadsp.8 opendkim-testkey.8 \
+ opendkim.8
+
SUB_FILES= pkg-message
+OPTIONS= \
+ ARLIB "Asynchronous thread-safe DNS library" On \
+ LUA "Describe filter policy with lua" Off \
+ OPENDBX "Store filter policies via OpenDBX" Off \
+ OPENLDAP "Store filter policies in LDAP" Off \
+ OPENSSL_PORT "Use OpenSSL in ports" Off \
+ POPAUTH "Use POP authentication DB" Off \
+ QUERY_CACHE "Cache DNS query results locally" Off \
+ UNBOUND "Use unbound DNS library" Off
+
+MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+
.include <bsd.port.pre.mk>
WITHOUT_MILTER_CFLAGS= yes
@@ -48,14 +56,22 @@ CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
CONFIGURE_ARGS+= --enable-debug
.endif
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.else
+CONFIGURE_ARGS+=--docdir=${WRKDIR}/doc
+.endif
+
.if (defined(WITH_POPAUTH) \
|| defined(WITH_QUERY_CACHE) \
|| defined(WITH_BODYLENGTH_DB) \
+ || defined(WITH_LDAP_CACHING) \
|| defined(WITH_STATS)) \
&& !defined(WITH_BDB_BASE)
-#BROKEN= LIBDB_INCDIR nor LIBDB_LIBDIRS cannot be set individually
-CONFIGURE_ARGS+= --with-db
-USE_BDB= 41+
+CONFIGURE_ARGS+= --with-db-incdir=${BDB_INCLUDE_DIR} \
+ --with-db-libdir=${BDB_LIB_DIR} \
+ --with-db-lib=${BDB_LIB_NAME}
+USE_BDB= 41+
.endif
.if defined(WITH_UNBOUND) && !defined(WITHOUT_UNBOUND)
BROKEN= configure fails since arlib cannot be disabled
@@ -64,12 +80,13 @@ IGNORE= libar cannot be used simultaneously with libunbound
.endif
CONFIGURE_ARGS+= --with-unbound \
--disable-arlib
-LIB_DEPENDS+= unbound:${PORTSDIR}/dns/unbound
+LIB_DEPENDS+= unbound:${PORTSDIR}/dns/unbound
PLIST_SUB+= ARLIB="@comment "
.else
-.if !defined(WITHOUT_ARLIB)
+.if defined(WITH_ARLIB)
PLIST_SUB+= ARLIB=""
CONFIGURE_ARGS+= --enable-arlib
+MAN3= ar.3
.else
CONFIGURE_ARGS+= --disable-arlib
PLIST_SUB+= ARLIB="@comment "
@@ -79,13 +96,25 @@ PLIST_SUB+= ARLIB="@comment "
CONFIGURE_ARGS+= --enable-popauth
.endif
.if defined(WITH_QUERY_CACHE) && !defined(WITHOUT_QUERY_CACHE)
-CONFIGURE_ARGS+= --enable-querycache
+CONFIGURE_ARGS+= --enable-query_cache
+.endif
+.if defined(WITH_OPENDBX)
+CONFIGURE_ARGS+= --with-odbx
+LIB_DEPENDS+= opendbx:${PORTSDIR}/databases/opendbx
+.endif
+.if defined(WITH_OPENLDAP)
+CONFIGURE_ARGS+= --with-openldap
+USE_OPENLDAP= yes
+.endif
+.if defined(WITH_LUA)
+CONFIGURE_ARGS+= --with-lua
+MAN3+= opendkim-lua.3
+MAN8+= miltertest.8
+PLIST_SUB+= LUA=""
+USE_LUA= 5.1
+.else
+PLIST_SUB+= LUA="@comment "
.endif
-
-post-extract:
-.for f in ${PORTDOCS0}
- @${CP} ${WRKSRC}/${f} ${WRKSRC}/docs/
-.endfor
post-install:
.if !defined(WITH_DEBUG)
@@ -93,13 +122,6 @@ post-install:
.endif
@${MKDIR} ${PREFIX}/etc/mail
${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample ${PREFIX}/etc/mail/
-.if !defined(NOPORTDOCS)
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.else
- @${RM} -rf ${DOCSDIR}
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>