aboutsummaryrefslogtreecommitdiffstats
path: root/mail/opensmtpd-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/opensmtpd-devel/Makefile')
-rw-r--r--mail/opensmtpd-devel/Makefile94
1 files changed, 94 insertions, 0 deletions
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
new file mode 100644
index 000000000000..d8d445045755
--- /dev/null
+++ b/mail/opensmtpd-devel/Makefile
@@ -0,0 +1,94 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= opensmtpd
+PORTVERSION= 201306271531
+CATEGORIES= mail
+MASTER_SITES= http://www.opensmtpd.org/archives/ \
+ http://distfiles.pirateparty.in/ashish/
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}-${PORTVERSION}p1
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= OpenSMTPD is a free MTA (development snapshot)
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
+
+OPENSMTPD_SNAPSHOT_VER= p1
+
+OPTIONS_DEFINE= PAM SQLITE MYSQL PGSQL LDAP
+
+OPTIONS_DEFAULT= PAM
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/
+
+USE_RC_SUBR= smtpd
+SUB_FILES= pkg-install pkg-deinstall
+
+CONFLICTS_INSTALL= postfix-[0-9]* sendmail-[0-9]* opensmtpd-[0-9]*
+
+MAN8= makemap.8 newaliases.8 smtpctl.8 smtpd.8
+MAN5= smtpd.conf.5 aliases.5 forward.5
+
+USERS= _smtpd _smtpq
+GROUPS= _smtpd
+
+.include <bsd.port.options.mk>
+
+USE_OPENSSL= yes
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_MYSQL= yes
+CFLAGS+= -I${LOCALBASE}/include/mysql
+LDFLAGS+= -L${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+= --with-experimental-mysql
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_SQLITE= 3
+CONFIGURE_ARGS+= --with-experimental-sqlite
+PLIST_SUB+= SQLITE=""
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.else
+PLIST_SUB+= SQLITE="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --with-experimental-postgres
+PLIST_SUB+= PGSQL=""
+.else
+PLIST_SUB+= PGSQL="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+CONFIGURE_ARGS+= --with-experimental-ldap
+PLIST_SUB+= LDAP=""
+.else
+PLIST_SUB+= LDAP="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPAM}
+CONFIGURE_ARGS+= --with-pam
+.endif
+
+# FreeBSD 7.3 and earlier need to use OpenSSL from ports
+.if ${OSVERSION} < 704000
+WITH_OPENSSL_PORT= yes
+.endif
+
+post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+post-deinstall:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
+
+.include <bsd.port.mk>