aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Email-Send/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/p5-Email-Send/Makefile')
-rw-r--r--mail/p5-Email-Send/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/mail/p5-Email-Send/Makefile b/mail/p5-Email-Send/Makefile
new file mode 100644
index 000000000000..628fafd6c316
--- /dev/null
+++ b/mail/p5-Email-Send/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: mail/p5-Email-Send
+# Date created: 27 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Send
+PORTVERSION= 2.00
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Email::Send - Simply Sending Email
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
+ ${SITE_PERL}/Return/Value.pm:${PORTSDIR}/devel/p5-Return-Value \
+ ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Email/Address.pm:${PORTSDIR}/mail/p5-Email-Address \
+ p5-Net>0:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::Send.3 \
+ Email::Send::IO.3 \
+ Email::Send::NNTP.3 \
+ Email::Send::Qmail.3 \
+ Email::Send::SMTP.3 \
+ Email::Send::Sendmail.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>