aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pine4/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail/pine4/files')
-rw-r--r--mail/pine4/files/patch-ac63
-rw-r--r--mail/pine4/files/patch-af23
-rw-r--r--mail/pine4/files/patch-ai70
-rw-r--r--mail/pine4/files/patch-ak37
-rw-r--r--mail/pine4/files/patch-al50
-rw-r--r--mail/pine4/files/patch-ax19
-rw-r--r--mail/pine4/files/patch-bb13
-rw-r--r--mail/pine4/files/patch-pico_makefile.bsf13
-rw-r--r--mail/pine4/files/patch-pine_pine.hlp10
-rw-r--r--mail/pine4/files/patch-pine_screen.c15
-rw-r--r--mail/pine4/files/patch-reply.c44
11 files changed, 0 insertions, 357 deletions
diff --git a/mail/pine4/files/patch-ac b/mail/pine4/files/patch-ac
deleted file mode 100644
index 08aa8b1ffc6c..000000000000
--- a/mail/pine4/files/patch-ac
+++ /dev/null
@@ -1,63 +0,0 @@
-*** pine/osdep/os-bsf.h.orig Fri May 23 09:05:21 2003
---- pine/osdep/os-bsf.h Thu Aug 9 00:30:23 2007
-***************
-*** 87,93 ****
- NOTE: You'll also have to make sure the appropriate osdep/postreap.*
- file is included in the os-*.ic file for your system.
- ----*/
-! /* #define BACKGROUND_POST */
-
-
-
---- 87,93 ----
- NOTE: You'll also have to make sure the appropriate osdep/postreap.*
- file is included in the os-*.ic file for your system.
- ----*/
-! #define BACKGROUND_POST
-
-
-
-***************
-*** 209,214 ****
---- 209,216 ----
- #define DF_KBLOCK_PASSWD_COUNT "1"
- #define DF_REMOTE_ABOOK_HISTORY "3"
-
-+ #define DF_SPELLER "@@PREFIX@@/bin/ispell"
-+
- /*----------------------------------------------------------------------
- The default printer when pine starts up for the first time with no printer
- ----*/
-***************
-*** 250,255 ****
---- 252,264 ----
- #define MAX_SCREEN_COLS (170)
- #define MAX_SCREEN_ROWS (200)
-
-+ /*----------------------------------------------------------------------
-+ File name used to store the user's server/id/password triple between
-+ session. It is rooted in the same directory as the PINERC.
-+ ----*/
-+ #ifdef WITH_PASSFILE
-+ #define PASSFILE "@@PASSFILE@@"
-+ #endif
-
- /*----------------------------------------------------------------------
- Where to put the output of pine in debug mode. Files are created
-***************
-*** 280,286 ****
- 8
- 9 logs gross details of command execution
- ----*/
-! #define DEFAULT_DEBUG 2
-
-
-
---- 289,295 ----
- 8
- 9 logs gross details of command execution
- ----*/
-! #define DEFAULT_DEBUG 0
-
-
-
diff --git a/mail/pine4/files/patch-af b/mail/pine4/files/patch-af
deleted file mode 100644
index 35b7ad38cb51..000000000000
--- a/mail/pine4/files/patch-af
+++ /dev/null
@@ -1,23 +0,0 @@
---- imap/src/osdep/unix/Makefile.orig Tue Jun 22 13:56:05 2004
-+++ imap/src/osdep/unix/Makefile Sun Aug 22 15:51:12 2004
-@@ -99,7 +99,7 @@
- # Commands possibly overriden by the individual port
-
- ARRC=ar rc
--CC=cc
-+#CC=cc
- LN=ln -s
- RANLIB=ranlib
-
-@@ -219,8 +219,9 @@
- SPOOLDIR=/var \
- ACTIVEFILE=/usr/local/news/lib/active \
- RSHPATH=/usr/bin/rsh \
-- BASECFLAGS="-g -O -pipe" \
-- BASELDFLAGS="-lcrypt"
-+ LOCKPGM=$(PREFIX)/libexec/mlock \
-+ BASECFLAGS="-DNFSKLUDGE" \
-+ BASELDFLAGS="-lpam -lcrypt"
-
- bsi: # BSD/i386
- $(BUILD) `$(CAT) SPECIALS` OS=$@ \
diff --git a/mail/pine4/files/patch-ai b/mail/pine4/files/patch-ai
deleted file mode 100644
index 5687a2ae77a4..000000000000
--- a/mail/pine4/files/patch-ai
+++ /dev/null
@@ -1,70 +0,0 @@
-*** pine/send.c.orig Fri Aug 29 15:03:08 2003
---- pine/send.c Fri Sep 5 01:44:20 2003
-***************
-*** 8251,8263 ****
- body->subtype = cpystr("octet-stream");
- }
-
-! /*
-! * Apply maximal encoding regardless of previous
-! * setting. This segment's either not text, or is
-! * unlikely to be readable with > 30% of the
-! * text encoded anyway, so we might as well save space...
-! */
-! new_encoding = ENCBINARY; /* > 30% 8 bit chars */
- }
- }
-
---- 8251,8267 ----
- body->subtype = cpystr("octet-stream");
- }
-
-! if(body->type == TYPETEXT)
-! /* Use ENC8BIT rather than ENCBINARY for TEXT */
-! new_encoding = ENC8BIT;
-! else
-! /*
-! * Apply maximal encoding regardless of previous
-! * setting. This segment's either not text, or is
-! * unlikely to be readable with > 30% of the
-! * text encoded anyway, so we might as well save space...
-! */
-! new_encoding = ENCBINARY; /* > 30% 8 bit chars */
- }
- }
-
-***************
-*** 9278,9284 ****
-
- switch (body->encoding) { /* all else needs filtering */
- case ENC8BIT: /* encode 8BIT into QUOTED-PRINTABLE */
-! gf_link_filter(gf_8bit_qp, NULL);
- break;
-
- case ENCBINARY: /* encode binary into BASE64 */
---- 9282,9289 ----
-
- switch (body->encoding) { /* all else needs filtering */
- case ENC8BIT: /* encode 8BIT into QUOTED-PRINTABLE */
-! if(F_OFF(F_ENABLE_8BIT, ps_global)) /* unless 8BIT enabled */
-! gf_link_filter(gf_8bit_qp, NULL);
- break;
-
- case ENCBINARY: /* encode binary into BASE64 */
-***************
-*** 9392,9398 ****
- && !(so_puts(so, "Content-Transfer-Encoding: ")
- && so_puts(so, body_encodings[(body->encoding==ENCBINARY)
- ? ENCBASE64
-! : (body->encoding == ENC8BIT)
- ? ENCQUOTEDPRINTABLE
- : (body->encoding <= ENCMAX)
- ? body->encoding
---- 9397,9403 ----
- && !(so_puts(so, "Content-Transfer-Encoding: ")
- && so_puts(so, body_encodings[(body->encoding==ENCBINARY)
- ? ENCBASE64
-! : (body->encoding == ENC8BIT && F_OFF(F_ENABLE_8BIT, ps_global))
- ? ENCQUOTEDPRINTABLE
- : (body->encoding <= ENCMAX)
- ? body->encoding
diff --git a/mail/pine4/files/patch-ak b/mail/pine4/files/patch-ak
deleted file mode 100644
index 27702ef00648..000000000000
--- a/mail/pine4/files/patch-ak
+++ /dev/null
@@ -1,37 +0,0 @@
-*** imap/Makefile.orig Mon Jul 14 18:35:29 2003
---- imap/Makefile Fri Sep 5 01:44:20 2003
-***************
-*** 453,468 ****
- $(TOOLS)/$@ "$(LN)" src/ansilib c-client
- $(TOOLS)/$@ "$(LN)" src/charset c-client
- $(TOOLS)/$@ "$(LN)" src/osdep/$(SYSTEM) c-client
-! $(TOOLS)/$@ "$(LN)" src/mtest mtest
-! $(TOOLS)/$@ "$(LN)" src/ipopd ipopd
-! $(TOOLS)/$@ "$(LN)" src/imapd imapd
- $(TOOLS)/$@ "$(LN)" src/mailutil mailutil
- $(TOOLS)/$@ "$(LN)" src/mlock mlock
- $(TOOLS)/$@ "$(LN)" src/dmail dmail
- $(TOOLS)/$@ "$(LN)" src/tmail tmail
- $(LN) $(TOOLS)/$@ .
-
-! build: OSTYPE rebuild rebuildclean bundled
-
- OSTYPE:
- @echo Building c-client for $(BUILDTYPE)...
---- 453,468 ----
- $(TOOLS)/$@ "$(LN)" src/ansilib c-client
- $(TOOLS)/$@ "$(LN)" src/charset c-client
- $(TOOLS)/$@ "$(LN)" src/osdep/$(SYSTEM) c-client
-! # $(TOOLS)/$@ "$(LN)" src/mtest mtest
-! # $(TOOLS)/$@ "$(LN)" src/ipopd ipopd
-! # $(TOOLS)/$@ "$(LN)" src/imapd imapd
- $(TOOLS)/$@ "$(LN)" src/mailutil mailutil
- $(TOOLS)/$@ "$(LN)" src/mlock mlock
- $(TOOLS)/$@ "$(LN)" src/dmail dmail
- $(TOOLS)/$@ "$(LN)" src/tmail tmail
- $(LN) $(TOOLS)/$@ .
-
-! build: OSTYPE rebuild rebuildclean # bundled
-
- OSTYPE:
- @echo Building c-client for $(BUILDTYPE)...
diff --git a/mail/pine4/files/patch-al b/mail/pine4/files/patch-al
deleted file mode 100644
index e9d00ac969ce..000000000000
--- a/mail/pine4/files/patch-al
+++ /dev/null
@@ -1,50 +0,0 @@
---- build.orig Wed May 4 14:22:22 2005
-+++ build Tue Jan 24 14:44:41 2006
-@@ -423,8 +423,7 @@
- echo "| unencrypted. |"
- echo "+-----------------------------------------------------------+"
- echo ""
-- echo "Do you want to continue this build anyway? Type y or n please:"
-- read ans
-+ ans=y
- case "$ans" in
- y) echo "Building without SSL ..."
- touch sslnone
-@@ -451,7 +450,7 @@
- fi
- echo ''
-
-- echo "Making Pico and Pilot"
-+ echo "Making Pilot"
- cd "$PHOME/pico"
- eval echo make "$makeargs" -f makefile.$picotarg
- eval make "$makeargs" -f makefile.$picotarg
-@@ -480,14 +479,13 @@
- cd "$PHOME"
- if [ ! -d bin ] ; then mkdir bin; fi
- cd "$PHOME/bin"
-- rm -f pine mtest imapd mailutil pico pilot rpload rpdump ipop2d ipop3d
-+ rm -f pine mtest imapd mailutil pilot rpload rpdump ipop2d ipop3d
- if [ -s ../pine/pine ] ; then ln ../pine/pine pine ; fi
- if [ -s ../mtest/mtest ] ; then ln ../mtest/mtest mtest ; fi
- if [ -s ../mailutil/mailutil ] ; then ln ../mailutil/mailutil mailutil ; fi
- if [ -s ../imapd/imapd ] ; then ln ../imapd/imapd imapd ; fi
- if [ -s ../ipopd/ipop2d ] ; then ln ../ipopd/ipop2d ipop2d ; fi
- if [ -s ../ipopd/ipop3d ] ; then ln ../ipopd/ipop3d ipop3d ; fi
-- if [ -s ../pico/pico ] ; then ln ../pico/pico pico ; fi
- if [ -s ../pico/pilot ] ; then ln ../pico/pilot pilot ; fi
- if [ -s ../pine/rpload ] ; then ln ../pine/rpload rpload ; fi
- if [ -s ../pine/rpdump ] ; then ln ../pine/rpdump rpdump ; fi
-@@ -502,10 +500,10 @@
- cd "$PHOME"
- echo ''
- echo "Links to executables are in bin directory:"
-- size bin/pine bin/mtest bin/imapd bin/pico bin/pilot bin/rpdump bin/rpload bin/mailutil bin/ipop2d bin/ipop3d
-+ size bin/pine bin/pilot bin/rpdump bin/rpload
- case $maketarg in
- mnt) echo "Fixing stacksizes ..."
-- fixstk 64K bin/pine bin/pico bin/imapd bin/mtest bin/pilot
-+ fixstk 64K bin/pine bin/pilot
- esac
- if [ "$SSLWARN" = "1" ]
- then
diff --git a/mail/pine4/files/patch-ax b/mail/pine4/files/patch-ax
deleted file mode 100644
index 5e8c3ca662c8..000000000000
--- a/mail/pine4/files/patch-ax
+++ /dev/null
@@ -1,19 +0,0 @@
-*** pine/makefile.bsf.orig Mon Nov 24 22:47:28 2003
---- pine/makefile.bsf Sat May 22 14:31:22 2004
-***************
-*** 67,73 ****
- `cat $(CCLIENTDIR)/LDFLAGS`
-
- STDCFLAGS= -DBSDI -DSYSTYPE=\"BSF\" -DMOUSE
-! CFLAGS= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(LDAPCFLAGS) \
- $(LOCALPINECFLAGS) $(STDCFLAGS)
-
- OFILES= addrbook.o adrbkcmd.o adrbklib.o args.o bldaddr.o context.o filter.o \
---- 67,73 ----
- `cat $(CCLIENTDIR)/LDFLAGS`
-
- STDCFLAGS= -DBSDI -DSYSTYPE=\"BSF\" -DMOUSE
-! CFLAGS+= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(LDAPCFLAGS) \
- $(LOCALPINECFLAGS) $(STDCFLAGS)
-
- OFILES= addrbook.o adrbkcmd.o adrbklib.o args.o bldaddr.o context.o filter.o \
diff --git a/mail/pine4/files/patch-bb b/mail/pine4/files/patch-bb
deleted file mode 100644
index 622e72d41a04..000000000000
--- a/mail/pine4/files/patch-bb
+++ /dev/null
@@ -1,13 +0,0 @@
---- pine/init.c.orig Thu Jul 15 10:37:24 2004
-+++ pine/init.c Mon Aug 9 01:23:53 2004
-@@ -1547,6 +1547,10 @@
- * having a global fixedprc, since we don't need it anymore after this.
- */
- fixedprc = new_pinerc_s(SYSTEM_PINERC_FIXED);
-+#endif
-+
-+#ifdef DF_SPELLER
-+ GLO_SPELLER = cpystr(DF_SPELLER);
- #endif
-
- /*
diff --git a/mail/pine4/files/patch-pico_makefile.bsf b/mail/pine4/files/patch-pico_makefile.bsf
deleted file mode 100644
index e650ceb714d5..000000000000
--- a/mail/pine4/files/patch-pico_makefile.bsf
+++ /dev/null
@@ -1,13 +0,0 @@
---- pico/makefile.bsf.orig Tue Oct 23 15:18:36 2001
-+++ pico/makefile.bsf Tue Oct 11 15:52:20 2005
-@@ -56,8 +56,8 @@
- #
- # dependencies for the Unix versions of pico and libpico.a
- #
--all: pico pilot
--pico pilot: libpico.a
-+all: pilot
-+pilot: libpico.a
-
- pico: main.o
- $(CC) $(CFLAGS) main.o libpico.a $(LIBS) -o pico
diff --git a/mail/pine4/files/patch-pine_pine.hlp b/mail/pine4/files/patch-pine_pine.hlp
deleted file mode 100644
index 4c255da5fa53..000000000000
--- a/mail/pine4/files/patch-pine_pine.hlp
+++ /dev/null
@@ -1,10 +0,0 @@
---- pine/pine.hlp.orig 2007-08-09 00:17:46.000000000 -0700
-+++ pine/pine.hlp 2007-08-09 00:23:00.000000000 -0700
-@@ -996,6 +996,7 @@
- executable &lt;Unix search path&gt;/pine
- persnl cfg ~/.pinerc
- except cfg ~/.pinercex
-+ password ~/@@PASSFILE@@
- global cfg <!--#echo var="PINE_CONF_PATH"-->
- fixed cfg <!--#echo var="PINE_CONF_FIXED_PATH"-->
- local help <!--#echo var="PINE_INFO_PATH"-->
diff --git a/mail/pine4/files/patch-pine_screen.c b/mail/pine4/files/patch-pine_screen.c
deleted file mode 100644
index af76a22c9c59..000000000000
--- a/mail/pine4/files/patch-pine_screen.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- pine/screen.c.orig Wed Apr 7 10:35:42 2004
-+++ pine/screen.c Tue Aug 10 22:35:37 2004
-@@ -208,7 +208,12 @@
- char this_label[MAX_LABEL+1];
-
- j = 6*i - 1;
-+
-+ /*
-+ Change this line so that color works on cons25 terminals
- if(i == 1 && !label_color)
-+ */
-+ if(i == 1)
- max_column--; /* Some terminals scroll if you write in the
- lower right hand corner. If user has a
- label_color set we'll take our chances.
diff --git a/mail/pine4/files/patch-reply.c b/mail/pine4/files/patch-reply.c
deleted file mode 100644
index e3548a46b3cb..000000000000
--- a/mail/pine4/files/patch-reply.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- pine/reply.c.orig Fri Aug 29 14:43:38 2003
-+++ pine/reply.c Fri Sep 5 01:44:21 2003
-@@ -5183,7 +5183,10 @@
- char *
- generate_message_id()
- {
-- static short osec = 0, cnt = 0;
-+ struct timeval tp;
-+ struct timezone tzp;
-+ static short osec = 0;
-+ static char cnt;
- char *id;
- time_t now;
- struct tm *now_x;
-@@ -5191,14 +5194,11 @@
-
- now = time((time_t *)0);
- now_x = localtime(&now);
-- id = (char *)fs_get(128 * sizeof(char));
-+ id = (char *)fs_get(384 * sizeof(char));
-
-- if(now_x->tm_sec == osec)
-- cnt++;
-- else{
-- cnt = 0;
-- osec = now_x->tm_sec;
-- }
-+ cnt = 'A';
-+ if(gettimeofday(&tp, &tzp) == 0)
-+ cnt += (time_t)tp.tv_usec % ('Z' - 'A');
-
- hostpart = F_ON(F_ROT13_MESSAGE_ID, ps_global)
- ? rot13(ps_global->hostname)
-@@ -5207,8 +5207,8 @@
- if(!hostpart)
- hostpart = cpystr("huh");
-
-- sprintf(id,"<Pine.%.4s.%.20s.%02d%02d%02d%02d%02d%02d%X.%d@%.50s>",
-- SYSTYPE, pine_version, (now_x->tm_year) % 100, now_x->tm_mon + 1,
-+ sprintf(id,"<%d%02d%02d%02d%02d%02d.%c%d@%s>",
-+ (now_x->tm_year) + 1900, now_x->tm_mon + 1,
- now_x->tm_mday, now_x->tm_hour, now_x->tm_min, now_x->tm_sec,
- cnt, getpid(), hostpart);
-