aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postgrey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postgrey/Makefile')
-rw-r--r--mail/postgrey/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index f6a7cf8c1714..ad2488c804be 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -35,6 +35,9 @@ PGY_USERID?= 225
PGY_GROUPNAME?= ${PGY_USERNAME}
PGY_GROUPID?= ${PGY_USERID}
PGY_DIR?= /var/db/postgrey
+
+USERS= ${PGY_USERNAME}
+GROUPS= ${PGY_GROUPNAME}
MAN1= ${PORTNAME}.1 policy-test.1 postgreyreport.1
post-patch:
@@ -42,10 +45,8 @@ post-patch:
@${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' ${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
@${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PGY_DIR}#' ${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
-pre-su-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
@${POD2MAN} ${WRKSRC}/policy-test ${WRKSRC}/policy-test.1
@${POD2MAN} ${WRKSRC}/contrib/postgreyreport ${WRKSRC}/postgreyreport.1