aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qpopper
diff options
context:
space:
mode:
Diffstat (limited to 'mail/qpopper')
-rw-r--r--mail/qpopper/Makefile2
-rw-r--r--mail/qpopper/files/patch-popper::pop_updt.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 740a407b708f..2f21bbecf47c 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qpopper
PORTVERSION= 4.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
diff --git a/mail/qpopper/files/patch-popper::pop_updt.c b/mail/qpopper/files/patch-popper::pop_updt.c
new file mode 100644
index 000000000000..32465704ca44
--- /dev/null
+++ b/mail/qpopper/files/patch-popper::pop_updt.c
@@ -0,0 +1,16 @@
+--- popper/pop_updt.c.orig Tue Dec 14 17:18:10 2004
++++ popper/pop_updt.c Tue Dec 14 17:18:57 2004
+@@ -531,11 +531,13 @@
+ if ( fputs ( buffer, md ) == EOF )
+ break;
+
++ if ( p->bUpdate_status_hdrs ) {
+ sprintf ( buffer, "X-UIDL: %s", mp->uidl_str );
+ if ( fputs ( buffer, md ) == EOF )
+ break;
+ length += strlen ( buffer ) + 1; /* for CRLF */
+ lines ++;
++ }
+
+ for ( status_written = 0, inheader = 1;
+ fgets ( buffer, MAXMSGLINELEN, p->drop );