aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamilter
diff options
context:
space:
mode:
Diffstat (limited to 'mail/spamilter')
-rw-r--r--mail/spamilter/Makefile18
-rw-r--r--mail/spamilter/distinfo2
-rw-r--r--mail/spamilter/files/patch-libspf-util.c11
3 files changed, 18 insertions, 13 deletions
diff --git a/mail/spamilter/Makefile b/mail/spamilter/Makefile
index 8a28292a88a4..9963d72c60d2 100644
--- a/mail/spamilter/Makefile
+++ b/mail/spamilter/Makefile
@@ -7,11 +7,16 @@
PORTNAME= spamilter
PORTVERSION= 0.59
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.wanlink.com/spamilter/download/
+MASTER_SITE_SUBDIR= dinoex
EXTRACT_SUFX= .tgz
+PATCH_SITES= ${MASTER_SITE_LOCAL} \
+PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
+PATCHFILES= spamilter-0.59-2005-11-08.patch.gz
+
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A Sendmail LibMilter filter to block spam
@@ -51,7 +56,7 @@ IGNORE= is unusable because of resource starvation in threads
.if !defined(SENDMAIL_MILTER_IN_BASE)
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --sendmail_dir ${LOCALBASE}
+CONFIGURE_ARGS+= --sendmail_dir "${LOCALBASE}"
.endif
#CFLAGS+= -DDEBUG_TIMESTAMP
@@ -89,7 +94,16 @@ post-configure:
-e "s|^LIBDIRS=|#LIBDIRS=|" \
-e "s|/usr/local/bind|${LOCALBASE}/bind|" \
-e "s|/usr/local/|${PREFIX}/|" \
+ -e "s|<SUPPORT_POPAUTH\\([^>]*\\)>|\\1|" \
+ -e "s|<SUPPORT_LIBSPF[^>]*>| |" \
+ -e "s|<SUPPORT_SPF\\([^>]*\\)>| |" \
+ -e "s|<SUPPORT_PAM[^>]*>| |" \
+ -e "s|uam.[hco]| |" \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} \
+ -e "s|#define SUPPORT_LIBSPF|#undef SUPPORT_LIBSPF|" \
+ -e "s|#define SUPPORT_PAM|#undef SUPPORT_PAM|" \
+ ${WRKSRC}/config.h
.if ${OSVERSION} > 500000
${REINPLACE_CMD} \
-e "s| install-ipfwmtad | |" \
diff --git a/mail/spamilter/distinfo b/mail/spamilter/distinfo
index b38440795f2c..feae09f2d0b5 100644
--- a/mail/spamilter/distinfo
+++ b/mail/spamilter/distinfo
@@ -1,2 +1,4 @@
MD5 (spamilter-0.59.tgz) = 2a4b5769415f52636dab5e0d011524ad
SIZE (spamilter-0.59.tgz) = 113434
+MD5 (spamilter-0.59-2005-11-08.patch.gz) = cb6065b3d345db40472a9e5e94afd67a
+SIZE (spamilter-0.59-2005-11-08.patch.gz) = 5189
diff --git a/mail/spamilter/files/patch-libspf-util.c b/mail/spamilter/files/patch-libspf-util.c
deleted file mode 100644
index 25e4c5486a24..000000000000
--- a/mail/spamilter/files/patch-libspf-util.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libspf/util.c.orig Thu Apr 29 15:47:30 2004
-+++ libspf/util.c Sat Nov 27 08:32:05 2004
-@@ -61,7 +61,7 @@
- void _printf_dbg(u_int8_t level, const char *function, const char *format,...)
- {
- char _dbg_output[MAX_DEBUG_LEN];
-- va_list argptr = NULL;
-+ va_list argptr;
-
- #ifdef _SPF_DEBUG_LOGFILE
- FILE *fp = NULL;