aboutsummaryrefslogtreecommitdiffstats
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 1827fbe9c942..c5be070aa588 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tpop3d
PORTVERSION= 1.5.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail
MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
@@ -29,6 +29,7 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
PASSWDAUTH "Use /etc/passwd authentication" off \
FLATAUTH "Use /etc/passwd-style flat file authentication" off \
MAILDIR "Compile Maildir support" on \
+ MBOXINDICES "Save Mbox indices" off \
DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off \
FIX_PERLAUTH "Only try it if perl-auth coredumps" off
@@ -72,10 +73,14 @@ CONFIGURE_ARGS+= --enable-auth-flatfile
CONFIGURE_ARGS+= --enable-auth-passwd
.endif
-.if !defined(WITHOUT_MAILDIR)
+.if defined(WITH_MAILDIR)
CONFIGURE_ARGS+= --enable-mbox-maildir
.endif
+.if defined(WITH_MBOXINDICES)
+CONFIGURE_ARGS+= --enable-mbox-bsd-save-indices
+.endif
+
.if defined(WITH_DRAC)
CONFIGURE_ARGS+= --enable-drac
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac