aboutsummaryrefslogtreecommitdiffstats
path: root/mail/xpbiff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/xpbiff/Makefile')
-rw-r--r--mail/xpbiff/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/mail/xpbiff/Makefile b/mail/xpbiff/Makefile
new file mode 100644
index 000000000000..f1274be74cac
--- /dev/null
+++ b/mail/xpbiff/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: xpbiff
+# Date created: 2 April 1997
+# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME?= xpbiff
+PORTVERSION?= 1.27
+PORTREVISION= 3
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= sanpei
+
+DISTNAME= xpbiff
+DISTFILES= xpbiff-1.27-with-YOUBIN.tar.gz.uu
+
+MAINTAINER?= sanpei@FreeBSD.org
+COMMENT?= A replacement for xbiff that handles popup window with mail header
+
+USE_IMAKE= yes
+USE_XORG= xpm xaw xmu
+NO_INSTALL_MANPAGES= yes
+PLIST_FILES= bin/xpbiff
+WRKSRC= ${WRKDIR}/xpbiff
+
+.if defined(PREFIX) && ${PREFIX} != ${LOCALBASE}
+YOUBINBINDIR= ${PREFIX}
+.else
+YOUBINBINDIR= ${LOCALBASE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @(cd ${WRKDIR}; \
+ if [ ! -f ${DISTDIR}/${DISTNAME}.tar.gz ]; then \
+ uudecode -p ${DISTDIR}/${DISTFILES} | ${TAR} xzf -; \
+ else \
+ ${TAR} xzf ${DISTDIR}/${DISTNAME}.tar.gz; \
+ fi)
+
+pre-patch:
+ @(${RM} -rf ${WRKSRC}/LocPixmap.c; \
+ ${CP} ${FILESDIR}/LocPixmap.c ${WRKSRC} );
+
+post-patch:
+.if defined(YOUBIN)
+ @(cd ${WRKSRC}; ${PATCH} -s < ${FILESDIR}/xpbiff.youbin.diff );
+.endif
+ @${MV} ${WRKSRC}/config.h ${WRKSRC}/config.h.org
+ @${SED} "s=%YOUBINBINDIR%=${YOUBINBINDIR}/bin=" < ${WRKSRC}/config.h.org > ${WRKSRC}/config.h
+
+.include <bsd.port.post.mk>