aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/smtptrapd/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/mail/smtptrapd/Makefile b/mail/smtptrapd/Makefile
index 57628722a8d6..0aba2e3c0ff7 100644
--- a/mail/smtptrapd/Makefile
+++ b/mail/smtptrapd/Makefile
@@ -9,18 +9,14 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= RFC 2821 compliant SMTP service that always returns a 4xx soft error
-CFLAGS+= ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}
-
USE_RC_SUBR= smtptrapd
PLIST_FILES= bin/smtptrapd
-NO_STAGE= yes
do-build:
- @cd ${WRKSRC} && ${CC} ${CFLAGS} -o smtptrapd smtptrapd.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -o smtptrapd smtptrapd.c
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/smtptrapd ${PREFIX}/bin/
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${INSTALL_PROGRAM} ${WRKSRC}/smtptrapd ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>