aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/archiveopteryx-devel/Makefile2
-rw-r--r--mail/archiveopteryx-devel/files/patch-server_tlsthread.cpp11
-rw-r--r--mail/archiveopteryx/Makefile2
-rw-r--r--mail/archiveopteryx/files/patch-server_tlsthread.cpp11
4 files changed, 24 insertions, 2 deletions
diff --git a/mail/archiveopteryx-devel/Makefile b/mail/archiveopteryx-devel/Makefile
index a494714615c1..b001aa447bd8 100644
--- a/mail/archiveopteryx-devel/Makefile
+++ b/mail/archiveopteryx-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= archiveopteryx
PORTVERSION= 3.2.99.20160129
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
PKGNAMESUFFIX= -devel
diff --git a/mail/archiveopteryx-devel/files/patch-server_tlsthread.cpp b/mail/archiveopteryx-devel/files/patch-server_tlsthread.cpp
new file mode 100644
index 000000000000..bb0f90c58bb5
--- /dev/null
+++ b/mail/archiveopteryx-devel/files/patch-server_tlsthread.cpp
@@ -0,0 +1,11 @@
+--- server/tlsthread.cpp.orig 2017-01-10 15:06:31 UTC
++++ server/tlsthread.cpp
+@@ -93,7 +93,7 @@ void TlsThread::setup()
+ SSL_library_init();
+
+ ctx = ::SSL_CTX_new( SSLv23_server_method() );
+- int options = SSL_OP_ALL
++ long options = SSL_OP_ALL
+ // also try to pick the same ciphers suites more often
+ | SSL_OP_CIPHER_SERVER_PREFERENCE
+ // and don't use SSLv2, even if the client wants to
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index fd9a8f660147..21915218554b 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= archiveopteryx
PORTVERSION= 3.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= mail
MASTER_SITES= http://archiveopteryx.org/download/
diff --git a/mail/archiveopteryx/files/patch-server_tlsthread.cpp b/mail/archiveopteryx/files/patch-server_tlsthread.cpp
new file mode 100644
index 000000000000..d43d193746fd
--- /dev/null
+++ b/mail/archiveopteryx/files/patch-server_tlsthread.cpp
@@ -0,0 +1,11 @@
+--- server/tlsthread.cpp.orig 2017-01-10 15:10:07 UTC
++++ server/tlsthread.cpp
+@@ -93,7 +93,7 @@ void TlsThread::setup()
+ SSL_library_init();
+
+ ctx = ::SSL_CTX_new( SSLv23_server_method() );
+- int options = SSL_OP_ALL
++ long options = SSL_OP_ALL
+ // also try to pick the same ciphers suites more often
+ | SSL_OP_CIPHER_SERVER_PREFERENCE
+ // and don't use SSLv2, even if the client wants to