aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/sqlgrey/Makefile1
-rw-r--r--mail/sqlgrey/files/patch-ipv611
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 2174cb650469..36c0a640caef 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlgrey
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-1.8%20%28stable%29
diff --git a/mail/sqlgrey/files/patch-ipv6 b/mail/sqlgrey/files/patch-ipv6
new file mode 100644
index 000000000000..8be3f957e0a2
--- /dev/null
+++ b/mail/sqlgrey/files/patch-ipv6
@@ -0,0 +1,11 @@
+--- sqlgrey.orig 2013-09-27 06:51:40.913265753 -0500
++++ sqlgrey 2013-09-27 06:51:25.000000000 -0500
+@@ -1037,7 +1037,7 @@
+ return join(":", (split(/:/, $addr))[0..3]);
+ } else {
+ ## For Non-EUI64 or Non-Global-Unicast return the address
+- return $addr;
++ return join(":", (split(/:/, $addr))[0..3]);
+ }
+ }
+