aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/nmzmail/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/mail/nmzmail/Makefile b/mail/nmzmail/Makefile
index f9a43d7f3c43..47a33093070c 100644
--- a/mail/nmzmail/Makefile
+++ b/mail/nmzmail/Makefile
@@ -23,6 +23,18 @@ USE_GMAKE= yes
PLIST_FILES= bin/nmzmail
PORTDOCS= README NEWS
+pre-extract:
+.if !defined(MAX_MAIL_DIRS)
+ @ ${ECHO_MSG} "You can define MAX_MAIL_DIRS=n."
+ @ ${ECHO_MSG} "nmzmail will only process this many mailboxes, the default is 32."
+.endif
+
+post-extract:
+.if defined(MAX_MAIL_DIRS)
+ @ ${SED} -i.bak -e 's/MAX_MAIL_DIRS 32/MAX_MAIL_DIRS ${MAX_MAIL_DIRS}/' \
+ ${WRKSRC}/src/nmzmail.c
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/