aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src::verify.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index bb0ebb2e1000..ace951f894f4 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}+${EXISCAN_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_EXIM}
MASTER_SITE_SUBDIR= exim4
diff --git a/mail/exim/files/patch-src::verify.c b/mail/exim/files/patch-src::verify.c
new file mode 100644
index 000000000000..6579e0829129
--- /dev/null
+++ b/mail/exim/files/patch-src::verify.c
@@ -0,0 +1,22 @@
+#
+# Fix SEGV on long headers when verify = header_syntax is used
+# <http://www.guninski.com/exim1.html>
+#
+--- src/verify.c.orig Thu May 6 15:46:44 2004
++++ src/verify.c Thu May 6 15:47:27 2004
+@@ -1264,14 +1264,9 @@
+
+ if (recipient == NULL && Ustrcmp(errmess, "empty address") != 0)
+ {
+- uschar hname[64];
+- uschar *t = h->text;
+- uschar *tt = hname;
++ uschar *t;
+ uschar *verb = US"is";
+ int len;
+-
+- while (*t != ':') *tt++ = *t++;
+- *tt = 0;
+
+ /* Arrange not to include any white space at the end in the
+ error message. */