aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/elm+ME/Makefile3
-rw-r--r--mail/elm+ME/files/patch-search-fix24
2 files changed, 26 insertions, 1 deletions
diff --git a/mail/elm+ME/Makefile b/mail/elm+ME/Makefile
index a38df0848a44..d910400c47b8 100644
--- a/mail/elm+ME/Makefile
+++ b/mail/elm+ME/Makefile
@@ -7,6 +7,7 @@
PORTNAME= elm+ME
PORTVERSION= ${ELM_VERSION}.${ELM_REVISION}${ELM_PATCHLEVEL:S/_//}
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.elmme-mailer.org/ \
ftp://ftp.elmme-mailer.org/elmme-mailer.org/src/elm-2.4ME+/ \
@@ -220,7 +221,7 @@ rename-readmes:
# Pre-install
#
-pre-install: create-install-dirs backup-conf-files
+pre-su-install: create-install-dirs backup-conf-files
create-install-dirs:
@${MKDIR} ${CONF_DIR} ${LIB_DIR} ${SHLIB_DIR}
diff --git a/mail/elm+ME/files/patch-search-fix b/mail/elm+ME/files/patch-search-fix
new file mode 100644
index 000000000000..8f378c3156ff
--- /dev/null
+++ b/mail/elm+ME/files/patch-search-fix
@@ -0,0 +1,24 @@
+The meaningful part of the patch obtained from Kari E. Hurtta
+(elm+ME maintainer), which fixes a double-free in parsing of
+certain MIME e-mails. The patch should be included in the next
+release of elm.
+
+--- melib/mime_decode.c 25 Aug 2007 11:51:51 -0000 2.0
++++ melib/mime_decode.c 28 Oct 2007 07:39:29 -0000 2.2
+@@ -2525,11 +2525,13 @@
+ unlink(fname); /* Unlink was delayed */
+ *name = NULL;
+ }
+- free(fname);
+- }
+
+- if (!name)
+ free(fname);
++
++ } else {
++ if (!name)
++ free(fname);
++ }
+ return tmpfp;
+ }
+