aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt-devel/files/patch-imap-browse.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index b62e1e91ca72..8c2889bd69d5 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -117,7 +117,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.18
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
diff --git a/mail/mutt-devel/files/patch-imap-browse.c b/mail/mutt-devel/files/patch-imap-browse.c
new file mode 100644
index 000000000000..f46df88d3e80
--- /dev/null
+++ b/mail/mutt-devel/files/patch-imap-browse.c
@@ -0,0 +1,13 @@
+Index: imap/browse.c
+Obtained from: http://dev.mutt.org/trac/changeset/5401%3Abba92e401440/imap/browse.c?old=5378%3Aac00273b3a88&old_path=imap%2Fbrowse.c
+Bug description: http://dev.mutt.org/trac/ticket/3057
+===================================================================
+--- imap/browse.c
++++ imap/browse.c
+@@ -229,5 +229,5 @@
+ }
+
+- if (!imap_mxcmp(mx.mbox, idata->mailbox))
++ if (idata->ctx && !imap_mxcmp(mx.mbox, idata->mailbox))
+ {
+ state->new = idata->ctx->new;