aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt/files/extra-patch-maildir-mtime-nntp32
2 files changed, 21 insertions, 13 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index a3b4841167cb..a66e9b75438e 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mutt
PORTVERSION= 1.8.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES+= mail ipv6
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
diff --git a/mail/mutt/files/extra-patch-maildir-mtime-nntp b/mail/mutt/files/extra-patch-maildir-mtime-nntp
index eb799b43f03b..7162b524e223 100644
--- a/mail/mutt/files/extra-patch-maildir-mtime-nntp
+++ b/mail/mutt/files/extra-patch-maildir-mtime-nntp
@@ -1,16 +1,19 @@
---- PATCHES Dec 2002 17:44:54 -0000 3.6
-+++ PATCHES Feb 2004 13:19:42 -0000
+--- PATCHES.orig 2017-04-09 21:00:46 UTC
++++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.7.ust.maildir-mtime.2
---- browser.c.orig Tue Feb 8 10:29:57 2005
-+++ browser.c Tue Feb 8 10:29:58 2005
-@@ -31,4 +31,5 @@
+--- browser.c.orig 2017-04-09 20:49:44 UTC
++++ browser.c
+@@ -35,6 +35,7 @@
+ #ifdef USE_NNTP
#include "nntp.h"
#endif
+#include "mx.h"
#include <stdlib.h>
-@@ -473,4 +474,19 @@
+ #include <dirent.h>
+@@ -545,6 +546,21 @@ static void init_state (struct browser_s
+ menu->data = state->entry;
}
+static void check_maildir_times (BUFFY *buf, struct stat *st)
@@ -30,15 +33,20 @@
+
/* get list of all files/newsgroups with mask */
static int examine_directory (MUTTMENU *menu, struct browser_state *state,
-@@ -562,4 +578,5 @@
+ char *d, const char *prefix)
+@@ -634,6 +650,7 @@ static int examine_directory (MUTTMENU *
+ tmp = Incoming;
while (tmp && mutt_strcmp (buffer, tmp->path))
tmp = tmp->next;
+ check_maildir_times (tmp, &s);
- add_folder (menu, state, de->d_name, &s, NULL, (tmp) ? tmp->new : 0);
- }
-@@ -637,4 +654,5 @@
- mutt_pretty_mailbox (buffer);
+ if (tmp && Context &&
+ !mutt_strcmp (tmp->realpath, Context->realpath))
+ {
+@@ -737,6 +754,7 @@ static int examine_mailboxes (MUTTMENU *
+ strfcpy (buffer, NONULL(tmp->path), sizeof (buffer));
+ mutt_pretty_mailbox (buffer, sizeof (buffer));
+ check_maildir_times (tmp, &s);
- add_folder (menu, state, buffer, &s, NULL, tmp->new);
+ add_folder (menu, state, buffer, &s, tmp, NULL);
}
+ while ((tmp = tmp->next));