aboutsummaryrefslogtreecommitdiffstats
path: root/math/R/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/R/Makefile')
-rw-r--r--math/R/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index ae083f276144..ba23c66bc6fa 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= R
-PORTVERSION= 2.7.1
+PORTVERSION= 2.7.2
CATEGORIES= math lang
MASTER_SITES= http://cran.r-project.org/src/base/R-2/ \
ftp://cran.r-project.org/pub/R/src/base/R-2/ \
@@ -28,7 +28,7 @@ MASTER_SITES= http://cran.r-project.org/src/base/R-2/ \
http://www.ibiblio.org/pub/languages/R/CRAN/src/base/R-2/ \
http://www.bioconductor.org/CRAN/src/base/R-2/
-MAINTAINER= eric+fbports@vangyzen.net
+MAINTAINER= ports@FreeBSD.org
COMMENT= A language for statistical computing and graphics
OPTIONS= ATLAS "Use ATLAS instead of BLAS/LAPACK" off \
@@ -39,6 +39,7 @@ OPTIONS= ATLAS "Use ATLAS instead of BLAS/LAPACK" off \
GHOSTSCRIPT "Enable the [dev2]bitmap() graphics devices" on \
PCRE_PORT "Use PCRE port instead of bundled source" on \
DVI_MANUALS "Install DVI manuals (requires TeX)" off \
+ PDF_MANUALS "Install PDF manuals (requires TeX)" off \
INFO_MANUALS "Install GNU info manuals" on \
LETTER_PAPER "Use US Letter paper" off
@@ -134,6 +135,15 @@ PLIST_SUB+= DVI_MANUAL=""
PLIST_SUB+= DVI_MANUAL="@comment "
.endif
+.if defined(WITHOUT_PDF_MANUALS) && !defined(NOPORTDOCS)
+PLIST_SUB+= PDF_MANUAL="@comment "
+.else
+PLIST_SUB+= PDF_MANUAL=""
+BUILD_DEPENDS+= pdflatex:${PORTSDIR}/print/teTeX-base
+ALL_TARGET+= pdf
+INSTALL_TARGET+=install-pdf
+.endif
+
.if defined(WITH_INFO_MANUALS) && !defined(NOPORTDOCS)
ALL_TARGET+= info
INFO= R-FAQ R-admin R-data R-exts R-intro R-lang