aboutsummaryrefslogtreecommitdiffstats
path: root/math/aamath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/aamath/Makefile')
-rw-r--r--math/aamath/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index bea6045d0f38..57d192198056 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aamath
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= math textproc
MASTER_SITES= http://fuse.superglue.se/aamath/
@@ -18,8 +19,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES+= bin/${PORTNAME}
MAN1= aamath.1
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS= -lreadline
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= ${LOCALBASE}/lib/libreadline.so
+.endif
+
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>