aboutsummaryrefslogtreecommitdiffstats
path: root/math/asymptote/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/asymptote/Makefile')
-rw-r--r--math/asymptote/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 45c8e886e5cd..bdb26481ab72 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 2.04
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}/old/${PORTVERSION}
@@ -48,8 +48,12 @@ MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-latex=${LOCALBASE}/share/texmf/tex/latex
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
+CONFIGURE_ARGS+=--with-latex=${LOCALBASE}/share/texmf/tex/latex \
+ --with-context=${LOCALBASE}/share/texmf/tex/context/third
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" \
+ LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" \
+ CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr