aboutsummaryrefslogtreecommitdiffstats
path: root/math/bargraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/bargraph/Makefile')
-rw-r--r--math/bargraph/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/math/bargraph/Makefile b/math/bargraph/Makefile
new file mode 100644
index 000000000000..43c5c9b3f672
--- /dev/null
+++ b/math/bargraph/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: bargraph
+# Date created: 9 March 2012
+# Whom: Dereckson <dereckson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bargraph
+PORTVERSION= 4.7
+CATEGORIES= math
+MASTER_SITES= http://bargraphgen.googlecode.com/files/
+DISTNAME= bargraphgen-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Scriptable bar graph generator
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${LOCALBASE}/bin/fig2dev:${PORTSDIR}/print/transfig \
+ ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bargraph.pl ${PREFIX}/bin/bargraph
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+.if !defined (NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/samples/*.perf ${WRKSRC}/samples/*.png ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>