aboutsummaryrefslogtreecommitdiffstats
path: root/math/calc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/calc/Makefile')
-rw-r--r--math/calc/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/math/calc/Makefile b/math/calc/Makefile
index dad698968dc7..f7cc4f6ef067 100644
--- a/math/calc/Makefile
+++ b/math/calc/Makefile
@@ -19,4 +19,12 @@ USE_LDCONFIG= yes
MAN1= calc.1
+CALCPAGER?= more
+MAKE_ENV+= CALCPAGER="${CALCPAGER}" CAT="${CAT}" CHMOD="${CHMOD}" CP="${CP}" \
+ GMAKE="${GMAKE}" LN="${LN}" MKDIR="${MKDIR}" MV="${MV}" RM="${RM}" \
+ SED="${SED}" TOUCH="${TOUCH}" TRUE="${TRUE}"
+
+regression-test: build
+ ( cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} check )
+
.include <bsd.port.mk>