aboutsummaryrefslogtreecommitdiffstats
path: root/math/cln/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/cln/Makefile')
-rw-r--r--math/cln/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 7f1ff22072a0..32f0b70864ed 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -7,17 +7,22 @@
#
PORTNAME= cln
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.4
CATEGORIES= math devel
MASTER_SITES= ftp://ftp.ilog.fr/pub/Users/haible/gnu/ \
ftp://ftp.santafe.edu/pub/gnu/ \
ftp://ftpthep.physik.uni-mainz.de/pub/gnu/
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gmp.4:${PORTSDIR}/math/libgmp3
USE_LIBTOOL= yes
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --datadir=${PREFIX}/share/cln --infodir=${PREFIX}/info \
- --mandir=${PREFIX}/man
+ --mandir=${PREFIX}/man --with-gmp
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -25,6 +30,6 @@ INSTALLS_SHLIB= yes
MAN1= cln-config.1
pre-build:
- @(cd ${WRKSRC} ; ${LN} -s ${LOCALBASE}/bin/libtool .)
+ @(cd ${WRKSRC} ; ${LN} -sf ${LOCALBASE}/bin/libtool .)
.include <bsd.port.mk>