aboutsummaryrefslogtreecommitdiffstats
path: root/math/foma/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/foma/Makefile')
-rw-r--r--math/foma/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/foma/Makefile b/math/foma/Makefile
new file mode 100644
index 000000000000..215d021c54f3
--- /dev/null
+++ b/math/foma/Makefile
@@ -0,0 +1,25 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= foma
+PORTVERSION= 0.9.17
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A toolkit for constructing finite-state automata and transducers
+
+LICENSE= GPLv2
+
+USES= gmake
+USE_GCC= yes
+USE_LDCONFIG= yes
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_LIB} ${WRKSRC}/libfoma.a ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_LIB} ${WRKSRC}/libfoma.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfoma.so.0
+ cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so
+
+.include <bsd.port.mk>