aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnumeric/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gnumeric/Makefile')
-rw-r--r--math/gnumeric/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 38eac4e72346..9edf58e312bb 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -24,7 +24,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
USE_PYTHON= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
@@ -36,12 +37,9 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}-bonobo
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-install:
.for dir in share/gnome lib