aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnumeric2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gnumeric2/Makefile')
-rw-r--r--math/gnumeric2/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 8f106fe993da..9c3671c224f0 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: gnumeric
-# Version required: 0.25
+# Version required: 0.26
# Date created: 08 October 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.10 1999/04/08 18:08:34 steve Exp $
+# $Id: Makefile,v 1.11 1999/05/09 17:22:27 steve Exp $
#
-DISTNAME= gnumeric-0.25
+DISTNAME= gnumeric-0.26
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnumeric
@@ -19,20 +19,16 @@ RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
python:${PORTSDIR}/lang/python
LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
-# implicit dependencies:
-# gettext, xpm, gtk12, guile, gnomelibs
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
USE_PERL5= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE} --with-guile
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
-
-post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ --with-gnome=${PREFIX} --with-guile
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>