aboutsummaryrefslogtreecommitdiffstats
path: root/math/gotoblas
diff options
context:
space:
mode:
Diffstat (limited to 'math/gotoblas')
-rw-r--r--math/gotoblas/Makefile8
-rw-r--r--math/gotoblas/files/patch-dynamic.c14
2 files changed, 18 insertions, 4 deletions
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 642291c53609..caf9efed2258 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -107,15 +107,15 @@ do-build:
${CP} ${DISTDIR}/${DIST_SUBDIR}/${LARGE_FILE} ${WRKSRC}
${CP} ${DISTDIR}/${DIST_SUBDIR}/${TIMING_FILE} ${WRKSRC}
${MKDIR} ${WRKDIR}/lib
- cd ${WRKSRC} && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=1 #DYNAMIC_ARCH=1
- cd ${WRKSRC}/exports && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=1 #DYNAMIC_ARCH=1
+ cd ${WRKSRC} && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=1 DYNAMIC_ARCH=1
+ cd ${WRKSRC}/exports && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=1 DYNAMIC_ARCH=1
${INSTALL_DATA} ${WRKSRC}/libgoto2.a ${WRKDIR}/lib/libgoto2p.a
${INSTALL_DATA} ${WRKSRC}/libgoto2.so ${WRKDIR}/lib/libgoto2p.so
cd ${WRKSRC} && ${GMAKE} clean
cd ${WRKSRC}/exports && ${GMAKE} clean
- cd ${WRKSRC} && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=0 #DYNAMIC_ARCH=1
- cd ${WRKSRC}/exports && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=0 #DYNAMIC_ARCH=1
+ cd ${WRKSRC} && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=0 DYNAMIC_ARCH=1
+ cd ${WRKSRC}/exports && ${GMAKE} ${MAKE_FLAGS} USE_THREAD=0 DYNAMIC_ARCH=1
${INSTALL_DATA} ${WRKSRC}/libgoto2.a ${WRKDIR}/lib/libgoto2.a
${INSTALL_DATA} ${WRKSRC}/libgoto2.so ${WRKDIR}/lib/libgoto2.so
diff --git a/math/gotoblas/files/patch-dynamic.c b/math/gotoblas/files/patch-dynamic.c
new file mode 100644
index 000000000000..84b4a44478a7
--- /dev/null
+++ b/math/gotoblas/files/patch-dynamic.c
@@ -0,0 +1,14 @@
+--- driver/others/dynamic.c~ 2010-01-21 01:28:45.000000000 +0900
++++ driver/others/dynamic.c 2010-02-16 13:43:09.000000000 +0900
+@@ -181,9 +181,9 @@
+ gotoblas = get_coretype();
+
+ #ifdef ARCH_X86
+- if (gotoblas == NULL) gotoblas = gotoblas_KATMAI;
++ if (gotoblas == NULL) gotoblas = &gotoblas_KATMAI;
+ #else
+- if (gotoblas == NULL) gotoblas = gotoblas_PRESCOTT;
++ if (gotoblas == NULL) gotoblas = &gotoblas_PRESCOTT;
+ #endif
+
+ if (gotoblas && gotoblas -> init) {