aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index b8c488a595b6..7a7480d11f3b 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gretl
-PORTVERSION= 1.0.9
+PORTVERSION= 1.1.0
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,15 +16,17 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Gnu Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack \
+ gmp.6:${PORTSDIR}/math/libgmp4
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GMAKE= yes
WANT_GNOME= yes
USE_GNOME= gnometarget gtk20 libxml2
-USE_AUTOCONF_VER= 253
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake
@@ -43,10 +45,7 @@ CONFIGURE_ARGS+= --without-gnome
PLIST_SUB+= GRETLDATADIR="share"
.endif
-.if defined(WITH_LAPACK)
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
-.else
-CONFIGURE_ARGS+= --with-lapack=no
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|libpng"|libpng12"|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>