aboutsummaryrefslogtreecommitdiffstats
path: root/math/libtsnnls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/libtsnnls/Makefile')
-rw-r--r--math/libtsnnls/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/libtsnnls/Makefile b/math/libtsnnls/Makefile
index 52ebacffe2d7..a8e3de0dced2 100644
--- a/math/libtsnnls/Makefile
+++ b/math/libtsnnls/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= tzhuan@gmail.com
COMMENT= Fast Sparse Nonnegative Least Squares Solver
GNU_CONFIGURE= yes
-USE_FORTRAN= yes
+USES= fortran
USE_LDCONFIG= yes
OPTIONS_DEFINE= GOTOBLAS ATLAS
@@ -50,6 +50,7 @@ BLAS=-lptf77blas
LAPACK=-lalapack -lptcblas
.endif
-CONFIGURE_ARGS= --with-blas="${BLAS}" --with-lapack="${LAPACK}"
+CONFIGURE_ARGS+=--with-blas="${BLAS}" --with-lapack="${LAPACK}"
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>