aboutsummaryrefslogtreecommitdiffstats
path: root/math/mathomatic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/mathomatic/Makefile')
-rw-r--r--math/mathomatic/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/math/mathomatic/Makefile b/math/mathomatic/Makefile
index 92f3670029dc..b66c7c403f16 100644
--- a/math/mathomatic/Makefile
+++ b/math/mathomatic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mathomatic
-PORTVERSION= 15.0.7
+PORTVERSION= 15.0.8
CATEGORIES= math
MASTER_SITES= http://www.panix.com/~gesslein/ \
CRITICAL
@@ -24,9 +24,23 @@ PORTDOCS= *
MAN1= mathomatic.1
+OPTIONS= PDF "Install PDF manual (requires htmldoc)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PDF)
+BUILD_DEPENDS+= htmldoc:${PORTSDIR}/textproc/htmldoc
+.endif
+
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+.if defined(WITH_PDF)
+post-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} pdf
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/mathomatic.1 ${PREFIX}/man/man1
@@ -46,4 +60,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>