aboutsummaryrefslogtreecommitdiffstats
path: root/math/metis4/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/metis4/files')
-rw-r--r--math/metis4/files/patch-aa27
-rw-r--r--math/metis4/files/patch-ab20
-rw-r--r--math/metis4/files/patch-ac11
-rw-r--r--math/metis4/files/patch-ad11
4 files changed, 69 insertions, 0 deletions
diff --git a/math/metis4/files/patch-aa b/math/metis4/files/patch-aa
new file mode 100644
index 000000000000..702a963c2189
--- /dev/null
+++ b/math/metis4/files/patch-aa
@@ -0,0 +1,27 @@
+--- Makefile.in.orig Sat Apr 25 23:41:58 1998
++++ Makefile.in Sat Apr 25 23:43:23 1998
+@@ -1,9 +1,9 @@
+
+ # Which compiler to use
+-CC = cc
++# CC = cc
+
+ # What optimization level to use
+-OPTFLAGS = -O2
++# OPTFLAGS = -O2
+
+ # What options to be used by the compiler
+ COPTIONS =
+@@ -12,10 +12,10 @@
+ LDOPTIONS =
+
+ # What archiving to use
+-AR = ar rv
++# AR = ar rv
+
+ # What to use for indexing the archive
+-RANLIB = ranlib
++# RANLIB = ranlib
+ # RANLIB = ar -ts
+ # RANLIB =
+
diff --git a/math/metis4/files/patch-ab b/math/metis4/files/patch-ab
new file mode 100644
index 000000000000..659723570fd9
--- /dev/null
+++ b/math/metis4/files/patch-ab
@@ -0,0 +1,20 @@
+--- Lib/Makefile.orig Sat Apr 25 23:43:54 1998
++++ Lib/Makefile Sat Apr 25 23:44:31 1998
+@@ -2,7 +2,7 @@
+
+ INCLUDES = -I./
+
+-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
++CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+ LD = $(CC) -L./
+
+
+@@ -17,7 +17,7 @@
+ $(CC) $(CFLAGS) -c $*.c
+
+ ../libmetis.a: $(OBJS)
+- $(AR) $@ $(OBJS)
++ $(AR) $(ARFLAGS) $@ $(OBJS)
+ $(RANLIB) $@
+
+ checkin:
diff --git a/math/metis4/files/patch-ac b/math/metis4/files/patch-ac
new file mode 100644
index 000000000000..dca2c7789b18
--- /dev/null
+++ b/math/metis4/files/patch-ac
@@ -0,0 +1,11 @@
+--- Programs/Makefile.orig Sat Apr 25 23:44:50 1998
++++ Programs/Makefile Sat Apr 25 23:46:35 1998
+@@ -3,7 +3,7 @@
+ BINDIR = ..
+
+ INCLUDES = -I../Lib
+-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
++CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+
+ LIBS = -lmetis -lm
+ LD = $(CC) $(LDOPTIONS) -L./ -L../
diff --git a/math/metis4/files/patch-ad b/math/metis4/files/patch-ad
new file mode 100644
index 000000000000..05210eefcaff
--- /dev/null
+++ b/math/metis4/files/patch-ad
@@ -0,0 +1,11 @@
+--- Test/Makefile.orig Sat Apr 25 23:46:45 1998
++++ Test/Makefile Sat Apr 25 23:46:53 1998
+@@ -3,7 +3,7 @@
+ BINDIR = ./
+
+ INCLUDES = -I../Lib
+-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
++CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+
+ LIBS = -lmetis -lm
+ LD = $(CC) $(LDOPTIONS) -L../