aboutsummaryrefslogtreecommitdiffstats
path: root/math/mpfr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/mpfr/Makefile')
-rw-r--r--math/mpfr/Makefile24
1 files changed, 5 insertions, 19 deletions
diff --git a/math/mpfr/Makefile b/math/mpfr/Makefile
index db850c0c1339..9461b0a4773c 100644
--- a/math/mpfr/Makefile
+++ b/math/mpfr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mpfr
PORTVERSION= 3.1.2
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= http://www.mpfr.org/mpfr-current/
DIST_SUBDIR= ${DISTNAME}
@@ -11,19 +12,18 @@ PATCH_SITES= ${MASTER_SITES}
PATCH_DIST_STRIP= -p1
MAINTAINER= ale@FreeBSD.org
-COMMENT= A library for multiple-precision floating-point computations
+COMMENT= Library for multiple-precision floating-point computations
LICENSE= LGPL3
#PATCH_DEPENDS= gpatch:${PORTSDIR}/devel/patch
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
#PATCHLEVEL= 10
#PATCHFILES!= /usr/bin/jot -s " " -w patch%02d ${PATCHLEVEL} 1 ${PATCHLEVEL}
#PATCH= ${LOCALBASE}/bin/gpatch
-USE_AUTOTOOLS= libtool
-USE_GNOME= ltverhack
+USES= libtool
USE_XZ= yes
GNU_CONFIGURE= yes
@@ -35,21 +35,7 @@ INFO= mpfr
PORTDOCS= *
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 803000
-CONFIGURE_ARGS+= --disable-thread-safe
-.endif
-
-.if ! ${PORT_OPTIONS:MDOCS}
-post-patch:
- @${REINPLACE_CMD} 's/install-nobase_dist_docDATA$$//' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} 's/install-data-am: install-dist_docDATA/install-data-am:/' \
- ${WRKSRC}/doc/Makefile.in
-.endif
-
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>