aboutsummaryrefslogtreecommitdiffstats
path: root/math/ocaml-zarith/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/ocaml-zarith/Makefile')
-rw-r--r--math/ocaml-zarith/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/math/ocaml-zarith/Makefile b/math/ocaml-zarith/Makefile
new file mode 100644
index 000000000000..aa7d75d5ff7f
--- /dev/null
+++ b/math/ocaml-zarith/Makefile
@@ -0,0 +1,45 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= zarith
+PORTVERSION= 1.2.1
+CATEGORIES= math
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/1199/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= OCaml arithmetic library for arbitrary precision integers
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+
+USES= gmake perl5 shebangfix tar:tgz
+USE_PERL5= build
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+OCAMLFIND_LDCONF= /dev/null
+HAS_CONFIGURE= yes
+ALL_TARGET= all
+SHEBANG_FILES= z_pp.pl
+CONFIGURE_ENV+= DESTDIR=${STAGEDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_JOBS_UNSAFE= yes
+PORTDOCS= html
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+ALL_TARGET+= doc
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MV} ${WRKSRC}/html ${STAGEDIR}${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>