aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave-forge-nan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-nan/Makefile')
-rw-r--r--math/octave-forge-nan/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-nan/Makefile b/math/octave-forge-nan/Makefile
index 39e6a16c9f64..3be88387fe0b 100644
--- a/math/octave-forge-nan/Makefile
+++ b/math/octave-forge-nan/Makefile
@@ -12,7 +12,11 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/NaN/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= NaN
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
@@ -21,6 +25,6 @@ ALL_TARGET= octave
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz NaN
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>