aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Algorithm-Munkres
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Algorithm-Munkres')
-rw-r--r--math/p5-Algorithm-Munkres/Makefile22
-rw-r--r--math/p5-Algorithm-Munkres/distinfo3
-rw-r--r--math/p5-Algorithm-Munkres/pkg-descr7
-rw-r--r--math/p5-Algorithm-Munkres/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/math/p5-Algorithm-Munkres/Makefile b/math/p5-Algorithm-Munkres/Makefile
new file mode 100644
index 000000000000..9e1702ef9575
--- /dev/null
+++ b/math/p5-Algorithm-Munkres/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Algorithm-Munkres
+# Date created: 2009-01-26
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Munkres
+PORTVERSION= 0.08
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl Extension for Munkres' Solution to Classical Assignment Problem
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::Munkres.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Algorithm-Munkres/distinfo b/math/p5-Algorithm-Munkres/distinfo
new file mode 100644
index 000000000000..5c0218831a5f
--- /dev/null
+++ b/math/p5-Algorithm-Munkres/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-Munkres-0.08.tar.gz) = 56349287513f955002720c8e2523582b
+SHA256 (Algorithm-Munkres-0.08.tar.gz) = 196bcda3984b179cedd847a7c16666b4f9741c07f611a65490d9e7f4b7a55626
+SIZE (Algorithm-Munkres-0.08.tar.gz) = 8608
diff --git a/math/p5-Algorithm-Munkres/pkg-descr b/math/p5-Algorithm-Munkres/pkg-descr
new file mode 100644
index 000000000000..a5360ad0d70a
--- /dev/null
+++ b/math/p5-Algorithm-Munkres/pkg-descr
@@ -0,0 +1,7 @@
+Algorithm-Munkres is a perl extension for Munkres' solution to
+classical Assignment problem for square and rectangular matrices
+This module extends the solution of Assignment problem for square
+matrices to rectangular matrices by padding zeros. Thus a rectangular
+matrix is converted to square matrix by padding necessary zeros.
+
+WWW: http://search.cpan.org/dist/Algorithm-Munkres/
diff --git a/math/p5-Algorithm-Munkres/pkg-plist b/math/p5-Algorithm-Munkres/pkg-plist
new file mode 100644
index 000000000000..3f0f91de4055
--- /dev/null
+++ b/math/p5-Algorithm-Munkres/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Munkres/.packlist
+%%SITE_PERL%%/Algorithm/Munkres.pm
+@dirrmtry %%SITE_PERL%%/Algorithm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Munkres
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm