aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Pari/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Math-Pari/Makefile')
-rw-r--r--math/p5-Math-Pari/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/p5-Math-Pari/Makefile b/math/p5-Math-Pari/Makefile
index d7230d59fee2..90db583a4c4c 100644
--- a/math/p5-Math-Pari/Makefile
+++ b/math/p5-Math-Pari/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= Math-Pari
-PORTVERSION= 2.01080607
-PORTREVISION= 1
+PORTVERSION= 2.01080800
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/00$//}
MAINTAINER= perl@FreeBSD.org
COMMENT= PARI - numerical/scientific/number-theoretic calculations
@@ -14,16 +14,16 @@ COMMENT= PARI - numerical/scientific/number-theoretic calculations
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/math/pari:configure
LIB_DEPENDS= libpari.so:${PORTSDIR}/math/pari
-USES= perl5
+USES= perl5 zip
USE_PERL5= configure
CONFIGURE_ARGS= parilib="-L${LOCALBASE}/lib -lpari" \
paridir=`${MAKE} -C ${PORTSDIR}/math/pari -V WRKSRC`
post-patch:
- ${REINPLACE_CMD} -e 's/2001004/2003000/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e 's|2001007|2003000|' ${WRKSRC}/Makefile.PL
post-clean:
- ${MAKE} -C ${PORTSDIR}/math/pari -DBATCH clean
+ @${MAKE_CMD} -C ${PORTSDIR}/math/pari -DBATCH clean
.include <bsd.port.mk>