aboutsummaryrefslogtreecommitdiffstats
path: root/math/pari/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/pari/Makefile')
-rw-r--r--math/pari/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/math/pari/Makefile b/math/pari/Makefile
index 4c4c0fbe4d6c..e2b8dd8cb0c1 100644
--- a/math/pari/Makefile
+++ b/math/pari/Makefile
@@ -24,30 +24,31 @@ PLIST_SUB= MAJOR_VERSION=${MAJOR_VERSION} MINOR_VERSION=${MINOR_VERSION} REV_VER
MAJOR_VERSION= 2
MINOR_VERSION= 3
-REV_VERSION= 3
+REV_VERSION= 4
MAN1= gp.1 gphelp.1 gp-${MAJOR_VERSION}.${MINOR_VERSION}.1 tex2mail.1
MLINKS= gp.1 pari.1
.include <bsd.port.pre.mk>
-post-install:
- @if [ -L ${PREFIX}/man/man1/pari.1 ]; then \
- ${RM} -f ${PREFIX}/man/man1/pari.1 ;\
- fi
-
HAVE_EMACS!= ${WHICH} emacs || ${ECHO} nope
HAVE_PERL!= ${WHICH} perl || ${ECHO} nope
+
.if ${HAVE_EMACS} != "nope"
-.if ${HAVE_PERL} != "nope"
-PLIST= ${PKGDIR}/pkg-plist.emacs.perl
+PLIST_SUB+= EMACS=""
.else
-PLIST= ${PKGDIR}/pkg-plit.emacs.noperl
+PLIST_SUB+= EMACS="@comment "
.endif
-.else
+
.if ${HAVE_PERL} != "nope"
-PLIST= ${PKGDIR}/pkg-plist.perl
-.endif
+PLIST_SUB+= PERL=""
+.else
+PLIST_SUB+= PERL="@comment "
.endif
+post-install:
+ @if [ -L ${PREFIX}/man/man1/pari.1 ]; then \
+ ${RM} -f ${PREFIX}/man/man1/pari.1 ;\
+ fi
+
.include <bsd.port.post.mk>