aboutsummaryrefslogtreecommitdiffstats
path: root/math/petsc
diff options
context:
space:
mode:
Diffstat (limited to 'math/petsc')
-rw-r--r--math/petsc/Makefile303
-rw-r--r--math/petsc/distinfo2
-rw-r--r--math/petsc/files/patch-bmake__common__rules.shared.basic13
-rw-r--r--math/petsc/files/patch-config_configure.py11
-rw-r--r--math/petsc/files/patch-makefile40
-rw-r--r--math/petsc/files/patch-python_PETSc_packages_spooles.py12
-rw-r--r--math/petsc/files/patch-src__mat__impls__aij__seq__umfpack__umfpack.c34
-rw-r--r--math/petsc/files/patch-src__mat__impls__rowbs__mpi__mpirowbs.h13
-rw-r--r--math/petsc/files/pkg-message.in5
-rw-r--r--math/petsc/pkg-descr9
-rw-r--r--math/petsc/pkg-plist282
11 files changed, 0 insertions, 724 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
deleted file mode 100644
index 12aeede0a036..000000000000
--- a/math/petsc/Makefile
+++ /dev/null
@@ -1,303 +0,0 @@
-# Created by: Thierry Thomas <thierry@pompo.net>
-# $FreeBSD$
-
-PORTNAME= petsc
-DISTVERSION= 2.3.3-p0
-PORTREVISION= 12
-PORTEPOCH= 1
-CATEGORIES= math parallel
-MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Portable, Extensible Toolkit for Scientific computation
-
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python \
- ksh:${PORTSDIR}/shells/pdksh \
- qsub:${PORTSDIR}/sysutils/torque
-
-HAS_CONFIGURE= yes
-USE_PYTHON= yes
-CONFIGURE_SCRIPT= config/configure.py
-CONFIGURE_LOG= configure.log
-CONFIGURE_ENV= PETSC_ARCH=${TARGET} \
- PETSC_DIR=${WRKSRC}
-CONFIGURE_ARGS= --prefix=${PREFIX}/${PFX} --COPTFLAGS="${CFLAGS}" \
- --CXXOPTFLAGS="${CXXFLAGS}" --FOPTFLAGS="${FFLAGS}" \
- --with-shared=1 --with-cc=${CC} --with-fc=${FC} \
- --CPPFLAGS="-I${LOCALBASE}/include" \
- --LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
-ALL_TARGET= all
-MAKEFILE= makefile
-MAKE_ENV= PETSC_DIR=${WRKSRC}
-
-SUB_FILES= pkg-message
-SUB_LIST= PETSC_ARCH=${TARGET} PETSC_DIR=${PREFIX}/${PFX}
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-.if !defined(WITHOUT_X11)
-USE_XORG= x11
-CONFIGURE_ARGS+= --with-x-include=${LOCALBASE}/include \
- --with-x-lib=${LOCALBASE}/lib/libX11.so
-.endif
-
-USES= fortran
-FFLAGS+= -O2
-PFX= ${PORTNAME}
-TARGET= ${OPSYS:tl}
-PLIST_SUB= PFX=${PFX} TARGET=${TARGET}
-
-.if !defined(WITHOUT_UMFPACK)
-UMFPACK_LIBS= umfpack.so,cholmod.so,colamd.so,amd.so,suitesparseconfig.so
-L=${LOCALBASE}/lib/lib
-LIB_DEPENDS+= libumfpack.so:${PORTSDIR}/math/suitesparse
-CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
- --with-umfpack-lib="[${UMFPACK_LIBS:C/^/${L}/:C/,/, ${L}/g}]"
-.endif
-
-NO_STAGE= yes
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-#USE_TEX= latex:build
-#BUILD_DEPENDS+= c2html:${PORTSDIR}/textproc/c2html \
-# doc2lt:${PORTSDIR}/textproc/sowing
-.endif
-
-LIBSCALAPACK= ${LOCALBASE}/lib/libscalapack.a
-LIBBLACS= ${LOCALBASE}/lib/libblacs.a
-MPIDIR= ${LOCALBASE}
-
-.if exists(${LOCALBASE}/mpi/openmpi/bin/mpirun)
-WITH_OPENMPI= yes
-MPIDIR= ${LOCALBASE}/mpi/openmpi
-.endif
-
-.if ${ARCH} == "amd64"
-WITHOUT_SUPERLU= yes
-.endif
-
-.if exists(${MPIDIR}/bin/mpicc) && !defined(WITHOUT_MPI)
-WITH_MPI= yes
-.endif
-.if defined(WITH_MPI)
-. if exists(${LOCALBASE}/bin/lamboot)
-BROKEN= Cannot build with MPI when lam-7 is installed - set WITHOUT_MPI or deinstall net/lam
-. endif
-.if defined(WITH_OPENMPI)
-MPIDIR= ${LOCALBASE}/mpi/openmpi
-BUILD_DEPENDS+= ${MPIDIR}/lib/libmpi.so:${PORTSDIR}/net/openmpi
-RUN_DEPENDS+= ${MPIDIR}/lib/libmpi.so:${PORTSDIR}/net/openmpi
-PKGNAMESUFFIX+= -openmpi
-MAKE_ENV+= PATH=${MPIDIR}/bin:${PATH}
-# math/blocksolve95 does not pass regression test when compiled with OpenMPI.
-WITHOUT_BS95= yes
-WITHOUT_SPOOLES= yes
-WITHOUT_PARMETIS= yes
-CONFIGURE_ARGS+= --with-cc=${MPIDIR}/bin/mpicc --with-fc=${MPIDIR}/bin/mpif77
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
-PKGNAMESUFFIX+= -mpich
-WITHOUT_SPOOLES= yes
-.endif
-
-CONFIGURE_ARGS+= --with-mpi-dir=${MPIDIR}
-CONFLICTS= petsc-2*
-PLIST_SUB+= MPIUNI="@comment "
-.else
-CONFIGURE_ARGS+= --with-mpi=0
-CONFLICTS= petsc-mpich-2*
-WITHOUT_BS95= yes
-WITHOUT_PARMETIS= yes
-WITHOUT_SPOOLES= yes
-WITHOUT_SUPERLU= yes
-PLIST_SUB+= MPIUNI=""
-.endif
-
-.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
-.endif
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
-LIBBLASLAPACK= -L${LOCALBASE}/lib -lalapack -lcblas -lf77blas
-CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
-.else
-LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
-LIBBLASLAPACK= -L${LOCALBASE}/lib -llapack -lblas
-CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
-.endif
-
-.if !defined(WITHOUT_SUPERLU) && !defined(WITHOUT_BLASLAPACK)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
-CONFIGURE_ARGS+= --with-superlu-include=${LOCALBASE}/include/superlu \
- --with-superlu-lib=${LOCALBASE}/lib/libsuperlu.a
-.endif
-
-.if defined(WITHOUT_BS95)
-CONFIGURE_ARGS+= --with-blocksolve95=0
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libBS95.a:${PORTSDIR}/math/blocksolve95
-CONFIGURE_ARGS+= --with-blocksolve95-include=${LOCALBASE}/include \
- --with-blocksolve95-lib=${LOCALBASE}/lib/libBS95.a
-.endif
-
-.if defined(WITHOUT_PARMETIS) || exists(${LOCALBASE}/lib/libmetis.so)
-# parmetis cannot be built with suitesparse
-CONFIGURE_ARGS+= --with-parmetis=0
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/lib/parmetis/libparmetis.a:${PORTSDIR}/math/parmetis
-CONFIGURE_ARGS+= --with-parmetis=1 \
- --with-parmetis-include=${LOCALBASE}/include/parmetis \
- --with-parmetis-lib=[${LOCALBASE}/lib/parmetis/libparmetis.a,${LOCALBASE}/lib/parmetis/libmetis.a]
-CONFLICTS+= metis-4*
-.endif
-
-.if exists(${LIBBLACS})
-WITH_BLACS= yes
-.endif
-.if defined(WITH_BLACS) && defined(WITH_MPI)
-LIB_DEPENDS+= libblacs.so:${PORTSDIR}/math/blacs
-CONFIGURE_ARGS+= --with_blacs=1 \
- --with-blacs-include=${LOCALBASE}/include \
- --with-blacs-lib=[${LOCALBASE}/lib/libblacsc.a,${LOCALBASE}/lib/libblacsf77.a,${LOCALBASE}/lib/libblacs.a]
-. if exists(${LIBSCALAPACK}) && defined(WITH_MPI)
-WITH_SCALAPACK= yes
-. endif
-. if defined(WITH_SCALAPACK)
-LIB_DEPENDS+= libscalapack.so:${PORTSDIR}/math/scalapack
-CONFIGURE_ARGS+= --with-scalapack=1 \
- --with-scalapack-dir=${LOCALBASE}
-. endif
-.endif
-
-#.if exists(${LOCALBASE}/bin/lgrind)
-#WITH_LGRIND= yes
-#.endif
-#.if defined(WITH_LGRIND)
-#BUILD_DEPENDS+= lgrind:${PORTSDIR}/print/lgrind
-#RUN_DEPENDS+= lgrind:${PORTSDIR}/print/lgrind
-#.endif
-
-.if exists(${LOCALBASE}/lib/libnetcdf.so)
-WITH_NETCDF= yes
-.endif
-.if defined(WITH_NETCDF)
-LIB_DEPENDS+= libnetcdf.so:${PORTSDIR}/science/netcdf
-CONFIGURE_ENV+= PNETCDF_INCLUDE=${LOCALBASE}/include \
- PNETCDF_LIB=${LOCALBASE}/lib
-.endif
-
-.if exists(${LOCALBASE}/bin/svn)
-WITH_SVN= yes
-.endif
-.if defined(WITH_SVN)
-BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-.endif
-
-#.if exists(${LOCALBASE}/bin/valgrind)
-#WITH_VALGRIND= yes
-#.endif
-#.if defined(WITH_VALGRIND)
-#BUILD_DEPENDS+= valgrind:${PORTSDIR}/devel/valgrind
-#RUN_DEPENDS+= valgrind:${PORTSDIR}/devel/valgrind
-#.endif
-
-.if !defined(WITHOUT_SPOOLES)
-. if exists(${LOCALBASE}/lib/libspooles.a) \
- && !exists(${LOCALBASE}/include/spooles/MPI/spoolesMPI.h)
-BROKEN= Please deinstall spooles and reinstall spooles-mpich
-. else
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libspooles.a:${PORTSDIR}/math/spooles-mpich
-. endif
-CONFIGURE_ARGS+= --with-spooles-include=${LOCALBASE}/include/spooles \
- --with-spooles-lib=[${LOCALBASE}/lib/libspooles.a,${LIBDIR}/libm.a]
-.endif
-
-pre-everything::
- @${ECHO_MSG}
-.if !defined (WITH_MPI)
- @${ECHO_MSG} "Define WITH_MPI to use MPI."
- @${ECHO_MSG} "Note: this is not compatible with Python bindings!"
-.elif !defined (WITHOUT_MPI)
- @${ECHO_MSG} "Define WITHOUT_MPI to not use MPI."
-.endif
-.if !defined (WITH_SVN)
- @${ECHO_MSG} "Define WITH_SVN to use subversion."
-.endif
-.if !defined (WITHOUT_X11)
- @${ECHO_MSG} "Define WITHOUT_X11 to remove X11 support."
-.endif
-.if !defined (WITH_ATLAS)
- @${ECHO_MSG} "Define WITH_ATLAS to replace Blas / Lapack support by Atlas."
-.endif
-.if !defined (WITHOUT_BS95)
- @${ECHO_MSG} "Define WITHOUT_BS95 to remove BlockSolve95 support."
-.endif
-.if !defined (WITHOUT_PARMETIS)
- @${ECHO_MSG} "Define WITHOUT_PARMETIS to remove ParMETIS support."
-.endif
-.if !defined (WITHOUT_SPOOLES)
- @${ECHO_MSG} "Define WITHOUT_SPOOLES to remove SPOOLES support."
-.endif
-#.if !defined (WITHOUT_SUPERLU)
-# @${ECHO_MSG} "Define WITHOUT_SUPERLU to remove SuperLU support."
-#.endif
-.if !defined (WITHOUT_UMFPACK)
- @${ECHO_MSG} "Define WITHOUT_UMFPACK to remove UMFPACK support."
-.endif
- @${ECHO_MSG}
-
-pre-configure:
- @${RM} ${WRKSRC}/bmake/common/rules.shared.basic.orig
- ${REINPLACE_CMD} -e "s|AMD/Include|include/AMD|" \
- -e "s|AMD/Lib|${LOCALBASE}/lib|" \
- ${WRKSRC}/python/PETSc/packages/UMFPACK.py
- ${REINPLACE_CMD} -e "s|/bin/ksh|${LOCALBASE}/bin/ksh|" \
- ${WRKSRC}/bin/popup
- @${RM} ${WRKSRC}/bin/popup.bak
-.if defined (WITH_MPI)
-. for ps in ml.py MPE.py
- ${REINPLACE_CMD} -e "s|-lpmpich|-lmpl|" \
- ${WRKSRC}/python/PETSc/packages/${ps}
-. endfor
- ${REINPLACE_CMD} -e "s|libpmpich|libmpl|" \
- ${WRKSRC}/python/BuildSystem/config/packages/MPI.py
-.endif
-
-post-install:
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bin
- ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bin
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bmake
- ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bmake
-.if ${PORT_OPTIONS:MDOCS}
- (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} ${MAKE_ARGS} install_docs)
-.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-
-.if defined(MAINTAINER_MODE)
-regression-test:
-. if defined (WITH_MPI) && !defined(WITH_OPENMPI)
-. if !exists(${HOME}/.mpd.conf)
- @${ECHO_CMD} "MPD_SECRETWORD=change_on_install" > ${HOME}/.mpd.conf
- ${CHMOD} go-r ${HOME}/.mpd.conf
- @${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
-. endif
- ${LOCALBASE}/bin/mpd &
-. endif
- (cd ${BUILD_WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
-. if defined (WITH_MPI) && !defined(WITH_OPENMPI)
- ${LOCALBASE}/bin/mpdallexit
-. endif
-.endif
-
-.include <bsd.port.mk>
diff --git a/math/petsc/distinfo b/math/petsc/distinfo
deleted file mode 100644
index f0222a42bfc1..000000000000
--- a/math/petsc/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (petsc-2.3.3-p0.tar.gz) = a08d0f2022349321a26ae6c63f0ad5b069d37f48028377c549b81cc3e7b97ddf
-SIZE (petsc-2.3.3-p0.tar.gz) = 10966078
diff --git a/math/petsc/files/patch-bmake__common__rules.shared.basic b/math/petsc/files/patch-bmake__common__rules.shared.basic
deleted file mode 100644
index f64f611487b7..000000000000
--- a/math/petsc/files/patch-bmake__common__rules.shared.basic
+++ /dev/null
@@ -1,13 +0,0 @@
---- bmake/common/rules.shared.basic.orig 2007-05-23 19:30:02.000000000 -0400
-+++ bmake/common/rules.shared.basic 2012-06-15 00:43:31.000000000 -0400
-@@ -10,6 +10,10 @@
- shared_solaris2: shared_solaris
- shared_solaris2_gnu: shared_solaris_gnu
-
-+shared_freebsd10: shared_freebsd
-+shared_freebsd9: shared_freebsd
-+shared_freebsd8: shared_freebsd
-+shared_freebsd7: shared_freebsd
- shared_freebsd6: shared_freebsd
- shared_freebsd5: shared_freebsd
- shared_freebsd4: shared_freebsd
diff --git a/math/petsc/files/patch-config_configure.py b/math/petsc/files/patch-config_configure.py
deleted file mode 100644
index e5be99315905..000000000000
--- a/math/petsc/files/patch-config_configure.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./config/configure.py.orig Sat Sep 2 02:24:13 2006
-+++ ./config/configure.py Sat Sep 2 23:23:33 2006
-@@ -97,7 +97,7 @@
- print ' *** Do not run configure as root, or using sudo. ***'
- print ' ***** That should be reserved for installation *****'
- print '================================================================================='
-- sys.exit(3)
-+ #sys.exit(3)
-
- # Check for broken cygwin
- if chkcygwin():
diff --git a/math/petsc/files/patch-makefile b/math/petsc/files/patch-makefile
deleted file mode 100644
index 22d6f88e3d34..000000000000
--- a/math/petsc/files/patch-makefile
+++ /dev/null
@@ -1,40 +0,0 @@
---- makefile.orig Sat Sep 2 03:57:37 2006
-+++ makefile Sat Sep 2 23:20:34 2006
-@@ -6,6 +6,7 @@
- ALL: all
- LOCDIR = ./
- DIRS = src include
-+DOCS_DIR = ${INSTALL_DIR}/../share/doc/petsc
- CFLAGS =
- FFLAGS =
-
-@@ -21,7 +22,7 @@
- echo " Do not run configure as root, or using sudo.";\
- echo " That should be reserved for installation";\
- echo "********************************************************************"; \
-- exit 1; fi
-+ fi
- @${OMAKE} PETSC_ARCH=${PETSC_ARCH} chkpetsc_dir
- -@${OMAKE} all_build 2>&1 | tee make_log_${PETSC_ARCH}
- -@egrep -i "( error | error:)" make_log_${PETSC_ARCH} > /dev/null; if [ "$$?" = "0" ]; then \
-@@ -261,14 +262,14 @@
- -@if [ "${INSTALL_DIR}" = "${PETSC_DIR}" ]; then \
- echo "You did not set a directory to install to";\
- else \
-- echo Installing PETSc documentation at ${INSTALL_DIR};\
-- if [ ! -d `dirname ${INSTALL_DIR}` ]; then \
-- ${MKDIR} `dirname ${INSTALL_DIR}` ; \
-+ echo Installing PETSc documentation at ${DOCS_DIR};\
-+ if [ ! -d `dirname ${DOCS_DIR}` ]; then \
-+ ${MKDIR} `dirname ${DOCS_DIR}` ; \
- fi;\
-- if [ ! -d ${INSTALL_DIR} ]; then \
-- ${MKDIR} ${INSTALL_DIR} ; \
-+ if [ ! -d ${DOCS_DIR} ]; then \
-+ ${MKDIR} ${DOCS_DIR} ; \
- fi;\
-- cp -fr docs ${INSTALL_DIR};\
-+ cp -fr docs/* ${DOCS_DIR};\
- ${RM} -fr docs/tex;\
- fi;
- # ------------------------------------------------------------------
diff --git a/math/petsc/files/patch-python_PETSc_packages_spooles.py b/math/petsc/files/patch-python_PETSc_packages_spooles.py
deleted file mode 100644
index 9184ce43136b..000000000000
--- a/math/petsc/files/patch-python_PETSc_packages_spooles.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./python/PETSc/packages/spooles.py.orig Thu Aug 11 01:08:42 2005
-+++ ./python/PETSc/packages/spooles.py Sun Aug 21 23:04:09 2005
-@@ -11,7 +11,8 @@
- self.download = ['ftp://ftp.mcs.anl.gov/pub/petsc/externalpackages/spooles-2.2.tar.gz']
- self.functions = ['InpMtx_init']
- self.includes = ['MPI/spoolesMPI.h']
-- self.liblist = [[os.path.join('MPI','src','spoolesMPI.a'),'spooles.a']]
-+ # FreeBSD: MPI is included in our spooles.a
-+ # self.liblist = [[os.path.join('MPI','src','spoolesMPI.a'),'spooles.a']]
- self.libdir = ''
- self.includedir = ''
- return
diff --git a/math/petsc/files/patch-src__mat__impls__aij__seq__umfpack__umfpack.c b/math/petsc/files/patch-src__mat__impls__aij__seq__umfpack__umfpack.c
deleted file mode 100644
index 030e253cb259..000000000000
--- a/math/petsc/files/patch-src__mat__impls__aij__seq__umfpack__umfpack.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/mat/impls/aij/seq/umfpack/umfpack.c.orig 2013-03-30 09:30:52.000000000 -0400
-+++ src/mat/impls/aij/seq/umfpack/umfpack.c 2013-03-30 09:32:20.000000000 -0400
-@@ -153,7 +153,7 @@
- PetscErrorCode ierr;
- int m=A->rmap.n,n=A->cmap.n,*ai=mat->i,*aj=mat->j,status,*ra,idx;
- PetscScalar *av=mat->a;
-- const char *strategy[]={"AUTO","UNSYMMETRIC","SYMMETRIC","2BY2"},
-+ const char *strategy[]={"AUTO","UNSYMMETRIC","SYMMETRIC"},
- *scale[]={"NONE","SUM","MAX"};
- PetscTruth flg;
-
-@@ -189,14 +189,12 @@
- case 0: lu->Control[UMFPACK_STRATEGY] = UMFPACK_STRATEGY_AUTO; break;
- case 1: lu->Control[UMFPACK_STRATEGY] = UMFPACK_STRATEGY_UNSYMMETRIC; break;
- case 2: lu->Control[UMFPACK_STRATEGY] = UMFPACK_STRATEGY_SYMMETRIC; break;
-- case 3: lu->Control[UMFPACK_STRATEGY] = UMFPACK_STRATEGY_2BY2; break;
- }
- }
- ierr = PetscOptionsReal("-mat_umfpack_dense_col","Control[UMFPACK_DENSE_COL]","None",lu->Control[UMFPACK_DENSE_COL],&lu->Control[UMFPACK_DENSE_COL],PETSC_NULL);CHKERRQ(ierr);
- ierr = PetscOptionsReal("-mat_umfpack_dense_row","Control[UMFPACK_DENSE_ROW]","None",lu->Control[UMFPACK_DENSE_ROW],&lu->Control[UMFPACK_DENSE_ROW],PETSC_NULL);CHKERRQ(ierr);
- ierr = PetscOptionsReal("-mat_umfpack_amd_dense","Control[UMFPACK_AMD_DENSE]","None",lu->Control[UMFPACK_AMD_DENSE],&lu->Control[UMFPACK_AMD_DENSE],PETSC_NULL);CHKERRQ(ierr);
- ierr = PetscOptionsReal("-mat_umfpack_block_size","Control[UMFPACK_BLOCK_SIZE]","None",lu->Control[UMFPACK_BLOCK_SIZE],&lu->Control[UMFPACK_BLOCK_SIZE],PETSC_NULL);CHKERRQ(ierr);
-- ierr = PetscOptionsReal("-mat_umfpack_2by2_tolerance","Control[UMFPACK_2BY2_TOLERANCE]","None",lu->Control[UMFPACK_2BY2_TOLERANCE],&lu->Control[UMFPACK_2BY2_TOLERANCE],PETSC_NULL);CHKERRQ(ierr);
- ierr = PetscOptionsReal("-mat_umfpack_fixq","Control[UMFPACK_FIXQ]","None",lu->Control[UMFPACK_FIXQ],&lu->Control[UMFPACK_FIXQ],PETSC_NULL);CHKERRQ(ierr);
- ierr = PetscOptionsReal("-mat_umfpack_aggressive","Control[UMFPACK_AGGRESSIVE]","None",lu->Control[UMFPACK_AGGRESSIVE],&lu->Control[UMFPACK_AGGRESSIVE],PETSC_NULL);CHKERRQ(ierr);
-
-@@ -291,7 +289,6 @@
- ierr = PetscViewerASCIIPrintf(viewer," Control[UMFPACK_DENSE_ROW]: %g\n",lu->Control[UMFPACK_DENSE_ROW]);CHKERRQ(ierr);
- ierr = PetscViewerASCIIPrintf(viewer," Control[UMFPACK_AMD_DENSE]: %g\n",lu->Control[UMFPACK_AMD_DENSE]);CHKERRQ(ierr);
- ierr = PetscViewerASCIIPrintf(viewer," Control[UMFPACK_BLOCK_SIZE]: %g\n",lu->Control[UMFPACK_BLOCK_SIZE]);CHKERRQ(ierr);
-- ierr = PetscViewerASCIIPrintf(viewer," Control[UMFPACK_2BY2_TOLERANCE]: %g\n",lu->Control[UMFPACK_2BY2_TOLERANCE]);CHKERRQ(ierr);
- ierr = PetscViewerASCIIPrintf(viewer," Control[UMFPACK_FIXQ]: %g\n",lu->Control[UMFPACK_FIXQ]);CHKERRQ(ierr);
- ierr = PetscViewerASCIIPrintf(viewer," Control[UMFPACK_AGGRESSIVE]: %g\n",lu->Control[UMFPACK_AGGRESSIVE]);CHKERRQ(ierr);
-
diff --git a/math/petsc/files/patch-src__mat__impls__rowbs__mpi__mpirowbs.h b/math/petsc/files/patch-src__mat__impls__rowbs__mpi__mpirowbs.h
deleted file mode 100644
index 4deb3db1d37b..000000000000
--- a/math/petsc/files/patch-src__mat__impls__rowbs__mpi__mpirowbs.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/mat/impls/rowbs/mpi/mpirowbs.h.orig Sat Oct 2 09:13:29 2004
-+++ src/mat/impls/rowbs/mpi/mpirowbs.h Tue Oct 5 21:58:07 2004
-@@ -5,8 +5,8 @@
- #include "src/mat/matimpl.h"
-
- EXTERN_C_BEGIN
--#include "BSsparse.h"
--#include "BSprivate.h"
-+#include <BSsparse.h>
-+#include <BSprivate.h>
- EXTERN_C_END
-
- /*
diff --git a/math/petsc/files/pkg-message.in b/math/petsc/files/pkg-message.in
deleted file mode 100644
index 9e26616e140e..000000000000
--- a/math/petsc/files/pkg-message.in
+++ /dev/null
@@ -1,5 +0,0 @@
-===================================================
-Before using PETSc, you'll have to set PETSC_DIR to
-%%PETSC_DIR%%
-and eventually PETSC_ARCH to %%PETSC_ARCH%%.
-===================================================
diff --git a/math/petsc/pkg-descr b/math/petsc/pkg-descr
deleted file mode 100644
index 7206a4e3e40d..000000000000
--- a/math/petsc/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-PETSc, the Portable, Extensible Toolkit for Scientific computation, provides
-sets of tools for the parallel (as well as serial), numerical solution of PDEs
-that require solving large-scale, sparse nonlinear systems of equations. PETSc
-includes nonlinear and linear equation solvers that employ a variety of Newton
-techniques and Krylov subspace methods. PETSc provides several parallel sparse
-matrix formats, including compressed row, block compressed row, and block
-diagonal storage.
-
-WWW: http://www.mcs.anl.gov/petsc/
diff --git a/math/petsc/pkg-plist b/math/petsc/pkg-plist
deleted file mode 100644
index 8b803a9670a2..000000000000
--- a/math/petsc/pkg-plist
+++ /dev/null
@@ -1,282 +0,0 @@
-%%PFX%%/bin/TOPSGenerator.py
-%%PFX%%/bin/TOPSGenerator.pyc
-%%PFX%%/bin/TOPSGenerator.pyo
-%%PFX%%/bin/TOPSInstaller.py
-%%PFX%%/bin/TOPSInstaller.pyc
-%%PFX%%/bin/TOPSInstaller.pyo
-%%PFX%%/bin/adiforfix.py
-%%PFX%%/bin/adiforfix.pyc
-%%PFX%%/bin/adiforfix.pyo
-%%PFX%%/bin/adprocess.py
-%%PFX%%/bin/adprocess.pyc
-%%PFX%%/bin/adprocess.pyo
-%%PFX%%/bin/chibaoutput
-%%PFX%%/bin/config/acconfig.h
-%%PFX%%/bin/config/aclocal.m4
-%%PFX%%/bin/config/config.guess
-%%PFX%%/bin/config/config.sub
-%%PFX%%/bin/config/findftnlibs
-%%PFX%%/bin/config/install-sh
-%%PFX%%/bin/configarch
-%%PFX%%/bin/hostnames.chiba
-%%PFX%%/bin/matlab/@freader/close.m
-%%PFX%%/bin/matlab/@freader/freader.m
-%%PFX%%/bin/matlab/@freader/read.m
-%%PFX%%/bin/matlab/@sreader/close.m
-%%PFX%%/bin/matlab/@sreader/read.m
-%%PFX%%/bin/matlab/@sreader/sreader.m
-%%PFX%%/bin/matlab/PetscBagRead.m
-%%PFX%%/bin/matlab/PetscBinaryRead.m
-%%PFX%%/bin/matlab/PetscBinaryWrite.m
-%%PFX%%/bin/matlab/PetscReadBinaryMatlab.m
-%%PFX%%/bin/matlab/launch.m
-%%PFX%%/bin/mpiexec.chiba
-%%PFX%%/bin/mpiexec.gmalloc
-%%PFX%%/bin/mpiexec.lam
-%%PFX%%/bin/mpiexec.llrun
-%%PFX%%/bin/mpiexec.poe
-%%PFX%%/bin/mpiexec.prun
-%%PFX%%/bin/mpiexec.sshsync
-%%PFX%%/bin/mpiexec.uni
-%%PFX%%/bin/mpiexec.valgrind
-%%PFX%%/bin/parseargs.py
-%%PFX%%/bin/parseargs.pyc
-%%PFX%%/bin/parseargs.pyo
-%%PFX%%/bin/petsc_libtool
-%%PFX%%/bin/petscmpiexec
-%%PFX%%/bin/popup
-%%PFX%%/bin/portabilitycheck.py
-%%PFX%%/bin/portabilitycheck.pyc
-%%PFX%%/bin/portabilitycheck.pyo
-%%PFX%%/bin/processSummary.py
-%%PFX%%/bin/processSummary.pyc
-%%PFX%%/bin/processSummary.pyo
-%%PFX%%/bin/taucc.py
-%%PFX%%/bin/taucc.pyc
-%%PFX%%/bin/taucc.pyo
-%%PFX%%/bin/update.py
-%%PFX%%/bin/update.pyc
-%%PFX%%/bin/update.pyo
-%%PFX%%/bin/urlget
-%%PFX%%/bin/urlget.py
-%%PFX%%/bin/urlget.pyc
-%%PFX%%/bin/urlget.pyo
-%%PFX%%/bin/win32fe/win32fe.exe
-%%PFX%%/bin/win32fe/win32feutils.dll
-%%PFX%%/bmake/adic.init
-%%PFX%%/bmake/adicmf.init
-%%PFX%%/bmake/adicmfb.init
-%%PFX%%/bmake/common/base
-%%PFX%%/bmake/common/rules
-%%PFX%%/bmake/common/rules.shared.basic
-%%PFX%%/bmake/common/test
-%%PFX%%/bmake/common/variables
-%%PFX%%/bmake/%%TARGET%%/RDict.db
-%%PFX%%/bmake/%%TARGET%%/configure.py
-%%PFX%%/bmake/%%TARGET%%/configure.pyc
-%%PFX%%/bmake/%%TARGET%%/configure.pyo
-%%PFX%%/bmake/%%TARGET%%/petscconf
-%%PFX%%/bmake/%%TARGET%%/petscconf.h
-%%PFX%%/bmake/%%TARGET%%/petscconfiginfo.h
-%%PFX%%/bmake/%%TARGET%%/petscfix.h
-%%PFX%%/bmake/%%TARGET%%/petscmachineinfo.h
-%%PFX%%/bmake/%%TARGET%%/petscrules
-%%PFX%%/bmake/petscconf
-%%PFX%%/include/adic/ad_deriv.h
-%%PFX%%/include/adic/ad_deriv.h.html
-%%PFX%%/include/adic/ad_grad.h
-%%PFX%%/include/adic/ad_grad.h.html
-%%PFX%%/include/adic/ad_grad_daxpy.h
-%%PFX%%/include/adic/ad_grad_daxpy.h.html
-%%PFX%%/include/adic/ad_grad_macro_axpys.h
-%%PFX%%/include/adic/ad_grad_macro_axpys.h.html
-%%PFX%%/include/adic/ad_utils.h
-%%PFX%%/include/adic/ad_utils.h.html
-%%PFX%%/include/adic/adintr_proto.h
-%%PFX%%/include/adic/adintr_proto.h.html
-%%PFX%%/include/adic/adintrinsics.h
-%%PFX%%/include/adic/adintrinsics.h.html
-%%PFX%%/include/adic/initcommon.h
-%%PFX%%/include/adic/initcommon.h.html
-%%PFX%%/include/adic/initenum.h
-%%PFX%%/include/adic/initenum.h.html
-%%PFX%%/include/adic/knr-compat.h
-%%PFX%%/include/adic/knr-compat.h.html
-%%PFX%%/include/adic/run-alloc.h
-%%PFX%%/include/adic/run-alloc.h.html
-%%PFX%%/include/adic/run-map.h
-%%PFX%%/include/adic/run-map.h.html
-%%PFX%%/include/finclude/index.html
-%%PFX%%/include/finclude/makefile
-%%PFX%%/include/finclude/makefile.html
-%%PFX%%/include/finclude/moddeps
-%%PFX%%/include/finclude/petsc.h
-%%PFX%%/include/finclude/petsc.h.html
-%%PFX%%/include/finclude/petscall.h
-%%PFX%%/include/finclude/petscall.h90
-%%PFX%%/include/finclude/petscao.h
-%%PFX%%/include/finclude/petscao.h.html
-%%PFX%%/include/finclude/petscbag.h
-%%PFX%%/include/finclude/petscda.h
-%%PFX%%/include/finclude/petscda.h.html
-%%PFX%%/include/finclude/petscda.h90
-%%PFX%%/include/finclude/petscda.h90.html
-%%PFX%%/include/finclude/petscdef.h
-%%PFX%%/include/finclude/petscdef.h.html
-%%PFX%%/include/finclude/petscdraw.h
-%%PFX%%/include/finclude/petscdraw.h.html
-%%PFX%%/include/finclude/petscerror.h
-%%PFX%%/include/finclude/petscis.h
-%%PFX%%/include/finclude/petscis.h.html
-%%PFX%%/include/finclude/petscis.h90
-%%PFX%%/include/finclude/petscis.h90.html
-%%PFX%%/include/finclude/petscksp.h
-%%PFX%%/include/finclude/petscksp.h.html
-%%PFX%%/include/finclude/petsclog.h
-%%PFX%%/include/finclude/petsclog.h.html
-%%PFX%%/include/finclude/petscmat.h
-%%PFX%%/include/finclude/petscmat.h.html
-%%PFX%%/include/finclude/petscmat.h90
-%%PFX%%/include/finclude/petscmat.h90.html
-%%PFX%%/include/finclude/petscmesh.h
-%%PFX%%/include/finclude/petscmesh.h90
-%%PFX%%/include/finclude/petscmg.h
-%%PFX%%/include/finclude/petscmg.h.html
-%%PFX%%/include/finclude/petscpc.h
-%%PFX%%/include/finclude/petscpc.h.html
-%%PFX%%/include/finclude/petscsnes.h
-%%PFX%%/include/finclude/petscsnes.h.html
-%%PFX%%/include/finclude/petscsys.h
-%%PFX%%/include/finclude/petscsys.h.html
-%%PFX%%/include/finclude/petscts.h
-%%PFX%%/include/finclude/petscts.h.html
-%%PFX%%/include/finclude/petscvec.h
-%%PFX%%/include/finclude/petscvec.h.html
-%%PFX%%/include/finclude/petscvec.h90
-%%PFX%%/include/finclude/petscvec.h90.html
-%%PFX%%/include/finclude/petscviewer.h
-%%PFX%%/include/finclude/petscviewer.h.html
-%%PFX%%/include/finclude/petscviewer.h90
-%%PFX%%/include/index.html
-%%PFX%%/include/makefile
-%%PFX%%/include/makefile.html
-%%PFX%%/include/mpiuni/mpi.h
-%%PFX%%/include/mpiuni/mpi.h.html
-%%PFX%%/include/mpiuni/mpif.h
-%%PFX%%/include/mpiuni/mpif.h.html
-%%PFX%%/include/petsc.h
-%%PFX%%/include/petsc.h.html
-%%PFX%%/include/petsc/petsc.h
-%%PFX%%/include/petsc/vec.h
-%%PFX%%/include/petscadic.h
-%%PFX%%/include/petscao.h
-%%PFX%%/include/petscao.h.html
-%%PFX%%/include/petscbag.h
-%%PFX%%/include/petscbag.h.html
-%%PFX%%/include/petscblaslapack.h
-%%PFX%%/include/petscblaslapack.h.html
-%%PFX%%/include/petscblaslapack_c.h
-%%PFX%%/include/petscblaslapack_caps.h
-%%PFX%%/include/petscblaslapack_cptofcd.h
-%%PFX%%/include/petscblaslapack_stdcall.h
-%%PFX%%/include/petscblaslapack_uscore.h
-%%PFX%%/include/petscbt.h
-%%PFX%%/include/petscbt.h.html
-%%PFX%%/include/petscctable.h
-%%PFX%%/include/petscda.h
-%%PFX%%/include/petscda.h.html
-%%PFX%%/include/petscdmmg.h
-%%PFX%%/include/petscdmmg.h.html
-%%PFX%%/include/petscdraw.h
-%%PFX%%/include/petscdraw.h.html
-%%PFX%%/include/petscerror.h
-%%PFX%%/include/petscerror.h.html
-%%PFX%%/include/petscis.h
-%%PFX%%/include/petscis.h.html
-%%PFX%%/include/petscksp.h
-%%PFX%%/include/petscksp.h.html
-%%PFX%%/include/petsclog.h
-%%PFX%%/include/petsclog.h.html
-%%PFX%%/include/petscmat.h
-%%PFX%%/include/petscmat.h.html
-%%PFX%%/include/petscmath.h
-%%PFX%%/include/petscmath.h.html
-%%PFX%%/include/petscmatlab.h
-%%PFX%%/include/petscmatlab.h.html
-%%PFX%%/include/petscmesh.h
-%%PFX%%/include/petscmg.h
-%%PFX%%/include/petscmg.h.html
-%%PFX%%/include/petscoptions.h
-%%PFX%%/include/petscoptions.h.html
-%%PFX%%/include/petscpc.h
-%%PFX%%/include/petscpc.h.html
-%%PFX%%/include/petscpf.h
-%%PFX%%/include/petscpf.h.html
-%%PFX%%/include/petscsnes.h
-%%PFX%%/include/petscsnes.h.html
-%%PFX%%/include/petscsys.h
-%%PFX%%/include/petscsys.h.html
-%%PFX%%/include/petsctime.h
-%%PFX%%/include/petsctime.h.html
-%%PFX%%/include/petscts.h
-%%PFX%%/include/petscts.h.html
-%%PFX%%/include/petscvec.h
-%%PFX%%/include/petscvec.h.html
-%%PFX%%/include/petscversion.h
-%%PFX%%/include/petscversion.h.html
-%%PFX%%/include/petscviewer.h
-%%PFX%%/include/petscviewer.h.html
-%%PFX%%/include/private/isimpl.h
-%%PFX%%/include/private/isimpl.h.html
-%%PFX%%/include/private/kspimpl.h
-%%PFX%%/include/private/kspimpl.h.html
-%%PFX%%/include/private/matimpl.h
-%%PFX%%/include/private/matimpl.h.html
-%%PFX%%/include/private/meshimpl.h
-%%PFX%%/include/private/pcimpl.h
-%%PFX%%/include/private/pcimpl.h.html
-%%PFX%%/include/private/petscimpl.h
-%%PFX%%/include/private/petscimpl.h.html
-%%PFX%%/include/private/snesimpl.h
-%%PFX%%/include/private/snesimpl.h.html
-%%PFX%%/include/private/tsimpl.h
-%%PFX%%/include/private/tsimpl.h.html
-%%PFX%%/include/private/vecimpl.h
-%%PFX%%/include/private/vecimpl.h.html
-%%PFX%%/include/zpetsc.h
-%%PFX%%/include/zpetsc.h.html
-%%MPIUNI%%%%PFX%%/lib/%%TARGET%%/libmpiuni.a
-%%PFX%%/lib/%%TARGET%%/libpetsc.a
-%%PFX%%/lib/%%TARGET%%/libpetsc.so
-%%PFX%%/lib/%%TARGET%%/libpetsccontrib.a
-%%PFX%%/lib/%%TARGET%%/libpetsccontrib.so
-%%PFX%%/lib/%%TARGET%%/libpetscdm.a
-%%PFX%%/lib/%%TARGET%%/libpetscdm.so
-%%PFX%%/lib/%%TARGET%%/libpetscksp.a
-%%PFX%%/lib/%%TARGET%%/libpetscksp.so
-%%PFX%%/lib/%%TARGET%%/libpetscmat.a
-%%PFX%%/lib/%%TARGET%%/libpetscmat.so
-%%PFX%%/lib/%%TARGET%%/libpetscsnes.a
-%%PFX%%/lib/%%TARGET%%/libpetscsnes.so
-%%PFX%%/lib/%%TARGET%%/libpetscts.a
-%%PFX%%/lib/%%TARGET%%/libpetscts.so
-%%PFX%%/lib/%%TARGET%%/libpetscvec.a
-%%PFX%%/lib/%%TARGET%%/libpetscvec.so
-@dirrm %%PFX%%/lib/%%TARGET%%
-@dirrm %%PFX%%/lib
-@dirrm %%PFX%%/include/private
-@dirrm %%PFX%%/include/petsc
-@dirrm %%PFX%%/include/mpiuni
-@dirrm %%PFX%%/include/finclude
-@dirrm %%PFX%%/include/adic
-@dirrm %%PFX%%/include
-@dirrm %%PFX%%/bmake/%%TARGET%%
-@dirrm %%PFX%%/bmake/common
-@dirrm %%PFX%%/bmake
-@dirrm %%PFX%%/bin/win32fe
-@dirrm %%PFX%%/bin/matlab/@sreader
-@dirrm %%PFX%%/bin/matlab/@freader
-@dirrm %%PFX%%/bin/matlab
-@dirrm %%PFX%%/bin/config
-@dirrm %%PFX%%/bin
-@dirrm %%PFX%%