aboutsummaryrefslogtreecommitdiffstats
path: root/math/pspp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/pspp/Makefile')
-rw-r--r--math/pspp/Makefile47
1 files changed, 38 insertions, 9 deletions
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index bb8349b41e43..47c87e2e301f 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pspp
-PORTVERSION= 0.4.0.1
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= math
MASTER_SITES= GNU
@@ -17,14 +16,44 @@ COMMENT= Program for statistical analysis of sampled data
LIB_DEPENDS= plot.4:${PORTSDIR}/graphics/plotutils \
gslcblas.0:${PORTSDIR}/math/gsl
-USE_GNOME= gnometarget
+OPTIONS= GUI "Build the PSPPIRE gui" off \
+ PGSQL "Compile in PostgreSQL capability" off
+
+USE_GNOME= gnometarget libxml2
USE_PERL5_BUILD=yes
-USE_GETTEXT= yes
+USE_ICONV= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+INFO= pspp pspp-dev
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITH_GUI)
+LIB_DEPENDS+= gladeui-1:${PORTSDIR}/devel/glade3
+USE_GNOME+= libglade2
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+= --without-gui
+PLIST_SUB+= GUI="@comment "
+.endif
-INFO= pspp
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+.else
+CONFIGURE_ARGS+= --without-libpq
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>