aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-ffc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-ffc/Makefile')
-rw-r--r--math/py-ffc/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/py-ffc/Makefile b/math/py-ffc/Makefile
new file mode 100644
index 000000000000..4b74dcb64117
--- /dev/null
+++ b/math/py-ffc/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-ffc
+# Date created: 12 April 2012
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffc
+PORTVERSION= 1.0.0
+CATEGORIES= math python
+MASTER_SITES= https://launchpad.net/${PORTNAME}/1.0.x/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= C++ code generator for multilinear forms
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= FFC
+
+FETCH_ARGS= -Fpr
+
+MAN1= ffc.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>