aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-sympy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-sympy/Makefile')
-rw-r--r--math/py-sympy/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/math/py-sympy/Makefile b/math/py-sympy/Makefile
index 31ff23918175..2ac326dc89d9 100644
--- a/math/py-sympy/Makefile
+++ b/math/py-sympy/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: py-sympy
-# Date created: 2008-08-09
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= sympy
-PORTVERSION= 0.7.1
+PORTVERSION= 0.7.2
CATEGORIES= math python
MASTER_SITES= GOOGLE_CODE \
CHEESESHOP
@@ -16,18 +12,18 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= A Python Library For Symbolic Mathematics
LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
MAN1= isympy.1
-OPTIONS= PYGLET "Enable plotting support" Off
+OPTIONS_DEFINE= PYGLET
+PYGLET_DESC= Enable plotting support
.include <bsd.port.options.mk>
-.if defined(WITH_PYGLET)
+.if ${PORT_OPTIONS:MPYGLET}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyglet>=1.1.2:${PORTSDIR}/graphics/py-pyglet
.endif